summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phar-utils-autoload.php9
-rw-r--r--php-seld-phar-utils.spec27
2 files changed, 19 insertions, 17 deletions
diff --git a/phar-utils-autoload.php b/phar-utils-autoload.php
deleted file mode 100644
index 622780c..0000000
--- a/phar-utils-autoload.php
+++ /dev/null
@@ -1,9 +0,0 @@
-<?php
-/* Autoloader for seld/phar-utils and its dependencies */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-\Fedora\Autoloader\Autoload::addPsr4('Seld\\PharUtils\\', __DIR__);
-
diff --git a/php-seld-phar-utils.spec b/php-seld-phar-utils.spec
index dc20ccb..7e97013 100644
--- a/php-seld-phar-utils.spec
+++ b/php-seld-phar-utils.spec
@@ -1,18 +1,18 @@
# remirepo/fedora spec file for php-seld-phar-utils
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 8800503d56b9867d43d9c303b9cbcc26016e82f0
+%global gh_commit ea2f4014f163c1be4c601b9b7bd6af81ba8d701c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Seldaek
%global gh_project phar-utils
Name: php-seld-phar-utils
-Version: 1.1.0
+Version: 1.2.1
Release: 1%{?dist}
Summary: PHAR file format utilities
@@ -20,15 +20,12 @@ License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# Autoloader
-Source1: %{gh_project}-autoload.php
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3
# For test
BuildRequires: php-cli
# Autoloader
-BuildRequires: php-composer(fedora/autoloader)
+BuildRequires: php-fedora-autoloader-devel
# From composer.json
# "php": ">=5.3.0",
@@ -54,7 +51,7 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-cp %{SOURCE1} src/autoload.php
+phpab --template fedora --output src/autoload.php src
%build
@@ -78,6 +75,7 @@ exit(0);
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md
@@ -86,6 +84,19 @@ exit(0);
%changelog
+* Mon Sep 12 2022 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+
+* Fri Dec 10 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- switch to classmap autoloader
+
+* Mon Aug 23 2021 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
+* Wed Jul 8 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Mon Feb 17 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0