summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-version3.spec14
3 files changed, 38 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 13d7ae9..e33d4d6 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"autoload": {
"classmap": [
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-version3.spec b/php-sebastian-version3.spec
index 21c6cdf..0a85dae 100644
--- a/php-sebastian-version3.spec
+++ b/php-sebastian-version3.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0411bde656dce64202b39c2f4473993a9081d39e
+%global gh_commit 626586115d0ed31cb71483be55beb759b5af5a3c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project version
@@ -18,16 +18,16 @@
%global ns_project Version
%global ver_major 3
%global php_home %{_datadir}/php
-%global with_tests %{?_without_tests:0}%{!?_withou_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 3.0.0
+Version: 3.0.1
Release: 1%{?dist}
Summary: Managing the version number of Git-hosted PHP projects
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -35,7 +35,7 @@ BuildRequires: php-cli
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.3.0"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
Requires: git
# Autoloader
@@ -83,6 +83,10 @@ exit (class_exists("%{ns_vendor}\\%{ns_project}") ? 0 : 1);
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1 (no change)
+- sources from git snapshot
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 7.3