summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-type2.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index da6da16..54c0a08 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.2"
diff --git a/php-sebastian-type2.spec b/php-sebastian-type2.spec
index b258c0e..9e3f95f 100644
--- a/php-sebastian-type2.spec
+++ b/php-sebastian-type2.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit bad49207c6f854e7a25cef0ea948ac8ebe3ef9d8
+%global gh_commit 56b3ba194e0cbaaf3de7ccd353c289d7a84ed022
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
@@ -21,13 +21,13 @@
%global ns_vendor SebastianBergmann
%global ns_project Type
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system
@@ -41,7 +41,7 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.2"
# ignore min version, test suite passes with 9.1
@@ -49,7 +49,7 @@ BuildRequires: phpunit9
%endif
# from composer.json, "require": {
-# "php": "^7.3",
+# "php": "^7.3 || ^8.0",
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -82,7 +82,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
@@ -115,6 +115,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0
- sources from git snapshot