summaryrefslogtreecommitdiffstats
path: root/php-sebastian-type.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-type.spec')
-rw-r--r--php-sebastian-type.spec115
1 files changed, 115 insertions, 0 deletions
diff --git a/php-sebastian-type.spec b/php-sebastian-type.spec
new file mode 100644
index 0000000..c308f73
--- /dev/null
+++ b/php-sebastian-type.spec
@@ -0,0 +1,115 @@
+# remirepo/fedora spec file for php-sebastian-type
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+# github
+%global gh_commit c2362deb2d0b708abe0c4a6d35633c19ae40cd4a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project type
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major %nil
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project Type
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Collection of value objects that represent the types of the PHP type system
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-reflection
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^8.2"
+# ignore min version, test suite passes with 8.1
+BuildRequires: phpunit8 > 8.1
+%endif
+
+# from composer.json, "require": {
+# "php": "^7.2",
+Requires: php(language) >= 7.2
+# from phpcompatinfo report for version 1.0.0: only core
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Collection of value objects that represent the types of the PHP type system.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+# For the test suite
+phpab --template fedora --output tests/autoload.php tests/_fixture/
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require_once 'tests/autoload.php';
+EOF
+
+: Run upstream test suite
+ret=0
+for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package