summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-type.spec11
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 5fc9c5e..5a2d622 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.2"
+ "php": ">=7.2"
},
"require-dev": {
"phpunit/phpunit": "^8.2"
diff --git a/php-sebastian-type.spec b/php-sebastian-type.spec
index 51fd2bb..283080f 100644
--- a/php-sebastian-type.spec
+++ b/php-sebastian-type.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit 3aaaa15fa71d27650d62a948be022fe3b48541a3
+%global gh_commit 0150cfbc4495ed2df3872fb31b26781e4e077eb4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.1.3
+Version: 1.1.4
Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system
@@ -48,7 +48,7 @@ BuildRequires: phpunit8 > 8.1
%endif
# from composer.json, "require": {
-# "php": "^7.2",
+# "php": ">=7.2",
Requires: php(language) >= 7.2
# from phpcompatinfo report for version 1.0.0: only core
# Autoloader
@@ -89,7 +89,7 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit8 --verbose || ret=1
@@ -112,6 +112,9 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- update to 1.1.4 (no change)
+
* Tue Jul 2 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
- update to 1.1.3