summaryrefslogtreecommitdiffstats
path: root/php-sebastian-object-reflector2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-object-reflector2.spec')
-rw-r--r--php-sebastian-object-reflector2.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-sebastian-object-reflector2.spec b/php-sebastian-object-reflector2.spec
index 2c9d7f4..cd43e15 100644
--- a/php-sebastian-object-reflector2.spec
+++ b/php-sebastian-object-reflector2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 14e04b3c25b821cc0702d4837803fe497680b062
+%global gh_commit 127a46f6b057441b201253526f81d5406d6c7840
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project object-reflector
@@ -20,13 +20,13 @@
%global major 2
%global php_home %{_datadir}/php
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Allows reflection of object attributes
@@ -38,14 +38,14 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -75,7 +75,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
%{_bindir}/phpab --output vendor/autoload.php tests/_fixture
cat << 'EOF' | tee -a vendor/autoload.php
@@ -106,6 +106,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1
- sources from git snapshot