summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-06 11:14:08 +0100
committerRemi Collet <remi@remirepo.net>2018-12-06 11:14:08 +0100
commitc7d65a8f6798ee645f6b86b43893bbf7892113de (patch)
tree78d86f42d7f9cc4f68db676ef9c47352c998f181
parentd08a3bb31725dbe430894e6b2f656829164399e9 (diff)
cleanup for EL-8HEADmaster
-rw-r--r--php-sebastian-object-enumerator3.spec9
1 files changed, 6 insertions, 3 deletions
diff --git a/php-sebastian-object-enumerator3.spec b/php-sebastian-object-enumerator3.spec
index b5d029e..6b138c7 100644
--- a/php-sebastian-object-enumerator3.spec
+++ b/php-sebastian-object-enumerator3.spec
@@ -26,7 +26,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 3.0.3
-%global specrel 2
+%global specrel 3
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Traverses array and object to enumerate all referenced objects
@@ -38,7 +38,7 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.0
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{pk_vendor}/object-reflector) >= 1.1.1 with php-composer(%{pk_vendor}/object-reflector) < 2)
BuildRequires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 4)
%else
@@ -55,7 +55,7 @@ BuildRequires: phpunit6
# "sebastian/object-reflector": "^1.1.1",
# "sebastian/recursion-context": "^3.0"
Requires: php(language) >= 7.0
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{pk_vendor}/object-reflector) >= 1.1.1 with php-composer(%{pk_vendor}/object-reflector) < 2)
Requires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 4)
%else
@@ -126,6 +126,9 @@ exit $ret
%changelog
+* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 3.0.3-3
+- cleanup for EL-8
+
* Tue Feb 6 2018 Remi Collet <remi@remirepo.net> - 3.0.3-2
- use range dependencies on F27+