summaryrefslogtreecommitdiffstats
path: root/php-sebastian-exporter4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-exporter4.spec')
-rw-r--r--php-sebastian-exporter4.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/php-sebastian-exporter4.spec b/php-sebastian-exporter4.spec
index 9589445..a656961 100644
--- a/php-sebastian-exporter4.spec
+++ b/php-sebastian-exporter4.spec
@@ -22,9 +22,9 @@
%global pear_name Exporter
%global pear_channel pear.phpunit.de
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
@@ -40,7 +40,7 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.2",
# "ext-mbstring": "*"
@@ -99,7 +99,7 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
-%if %{with_tests}
+%if %{with tests}
%check
mkdir vendor
touch vendor/autoload.php