summaryrefslogtreecommitdiffstats
path: root/php-sebastian-environment5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-environment5.spec')
-rw-r--r--php-sebastian-environment5.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-sebastian-environment5.spec b/php-sebastian-environment5.spec
index ec235e8..9a27f73 100644
--- a/php-sebastian-environment5.spec
+++ b/php-sebastian-environment5.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Sources
-%global gh_commit 16eb0fa43e29c33d7f2117ed23072e26fc5ab34e
+%global gh_commit 0a757cab9d5b7ef49a619f1143e6c9c1bc0fe9d2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -21,13 +21,13 @@
%global ns_vendor SebastianBergmann
%global ns_project Environment
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.1.1
+Version: 5.1.2
Release: 1%{?dist}
Summary: Handle HHVM/PHP environments
@@ -43,14 +43,14 @@ BuildRequires: php-pcre
BuildRequires: php-posix
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json, "require": {
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# From phpcompatinfo report for 4.0.1
Requires: php-pcre
@@ -83,7 +83,7 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
-%if %{with_tests}
+%if %{with tests}
%check
mkdir vendor
touch vendor/autoload.php
@@ -111,6 +111,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 5.1.2-1
+- update to 5.1.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 5.1.1-1
- update to 5.1.1
- sources from git snapshot