summaryrefslogtreecommitdiffstats
path: root/php-sebastian-diff4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-diff4.spec')
-rw-r--r--php-sebastian-diff4.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-sebastian-diff4.spec b/php-sebastian-diff4.spec
index 4da1743..dfcfeb6 100644
--- a/php-sebastian-diff4.spec
+++ b/php-sebastian-diff4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3e523c576f29dacecff309f35e4cc5a5c168e78a
+%global gh_commit 1e90b4cf905a7d06c420b1d2e9d11a4dc8a13113
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -21,13 +21,13 @@
%global major 4
%global php_home %{_datadir}/php
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.1
+Version: 4.0.2
Release: 1%{?dist}
Summary: Diff implementation
@@ -38,7 +38,7 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -50,7 +50,7 @@ BuildRequires: php-symfony4-process
%endif
# from composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 4.0.0
Requires: php-pcre
@@ -82,7 +82,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
%{_bindir}/phpab --output vendor/autoload.php tests
cat << 'EOF' | tee -a vendor/autoload.php
@@ -126,6 +126,9 @@ exit $ret
%changelog
+* Tue Jun 30 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
+- update to 4.0.2
+
* Fri May 8 2020 Remi Collet <remi@remirepo.net> - 4.0.1-1
- update to 4.0.1
- sources from git snapshot