summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-diff4.spec24
2 files changed, 14 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 63b04df..cf92202 100644
--- a/composer.json
+++ b/composer.json
@@ -23,10 +23,10 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.0",
+ "phpunit/phpunit": "^9.3",
"symfony/process": "^4.2 || ^5"
},
"autoload": {
diff --git a/php-sebastian-diff4.spec b/php-sebastian-diff4.spec
index dfcfeb6..3b795fd 100644
--- a/php-sebastian-diff4.spec
+++ b/php-sebastian-diff4.spec
@@ -6,8 +6,10 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 1e90b4cf905a7d06c420b1d2e9d11a4dc8a13113
+
+%bcond_without tests
+
+%global gh_commit ffc949a1a2aae270ea064453d7535b82e4c32092
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -20,16 +22,11 @@
%global major 4
%global php_home %{_datadir}/php
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.2
+Version: 4.0.3
Release: 1%{?dist}
-Summary: Diff implementation
+Summary: Diff implementation version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -43,14 +40,14 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0",
+# "phpunit/phpunit": "^9.3",
# "symfony/process": "^4.2 || ^5"
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.3
BuildRequires: php-symfony4-process
%endif
# from composer.json
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 4.0.0
Requires: php-pcre
@@ -126,6 +123,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
+- update to 4.0.3 (no change)
+
* Tue Jun 30 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
- update to 4.0.2