summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-04 15:16:34 +0100
committerRemi Collet <remi@php.net>2025-02-04 15:16:34 +0100
commit710d43830e2423111cb628b088dae09a63ab89f3 (patch)
tree523964f854dadda42f45c043664a74c1e10c8da0
dup v3
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json42
-rwxr-xr-xmakesrc.sh35
-rw-r--r--php-sebastian-cli-parser4.spec141
5 files changed, 231 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..efb0df1
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,42 @@
+{
+ "name": "sebastian/cli-parser",
+ "description": "Library for parsing CLI options",
+ "type": "library",
+ "homepage": "https://github.com/sebastianbergmann/cli-parser",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/cli-parser/issues",
+ "security": "https://github.com/sebastianbergmann/cli-parser/security/policy"
+ },
+ "prefer-stable": true,
+ "require": {
+ "php": ">=8.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^11.0"
+ },
+ "config": {
+ "platform": {
+ "php": "8.2.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-main": "3.0-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..b959795
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+DATE=$(date -d "$DATE -4 days" +%Y-%m-%d)
+
+if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
+ echo "$NAME-$VERSION-$SHORT.tgz already there"
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n"
+
+ echo "Cloning..."
+ rm -rf $PROJECT-$COMMIT
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+
+ echo "Getting commit..."
+ pushd $PROJECT-$COMMIT
+ git checkout $COMMIT || exit1
+ cp composer.json ../composer.json
+ popd
+
+ echo "Archiving..."
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+ echo "Cleaning..."
+ rm -rf $PROJECT-$COMMIT
+
+ echo "Done."
+fi
diff --git a/php-sebastian-cli-parser4.spec b/php-sebastian-cli-parser4.spec
new file mode 100644
index 0000000..a8ed575
--- /dev/null
+++ b/php-sebastian-cli-parser4.spec
@@ -0,0 +1,141 @@
+# remirepo/fedora spec file for php-sebastian-cli-parser3
+#
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+#
+# Please, preserve the changelog entries
+#
+
+# disabled until phpunit11 available
+%bcond_without tests
+
+# github
+%global gh_commit 15c5dd40dc4f38794d383bb95465193f5e0ae180
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project cli-parser
+%global gh_date 2024-07-03
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major 3
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project CliParser
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.0.2
+Release: 2%{?dist}
+Summary: Library for parsing CLI options, version %{major}
+
+License: BSD-3-Clause
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 8.2
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
+%endif
+
+# from composer.json, "require": {
+# "php": ">=8.2",
+Requires: php(language) >= 8.2
+# from phpcompatinfo report for version 2.0.0
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Library for parsing $_SERVER['argv'], extracted from phpunit/phpunit.
+
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+touch vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php php82 php83 php84; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit11 || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 3.0.2-2
+- enable test suite
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
+* Tue Mar 5 2024 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.2
+- rename to php-sebastian-cli-parser2
+- move to /usr/share/php/SebastianBergmann/CliParser3
+
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 2.0.0-3
+- Enable test suite
+
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP 8.1
+- rename to php-sebastian-cli-parser2
+- move to /usr/share/php/SebastianBergmann/CliParser2
+
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+
+* Thu Aug 13 2020 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package