summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--469.patch22
-rw-r--r--php-sabre-vobject4.spec8
2 files changed, 29 insertions, 1 deletions
diff --git a/469.patch b/469.patch
new file mode 100644
index 0000000..eae0b20
--- /dev/null
+++ b/469.patch
@@ -0,0 +1,22 @@
+From 785981177a296b855d7318e87e095a0ea56f9715 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 9 Oct 2019 09:11:46 +0200
+Subject: [PATCH] fix Bad file descriptor (7.4)
+
+---
+ tests/VObject/Parser/MimeDirTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/VObject/Parser/MimeDirTest.php b/tests/VObject/Parser/MimeDirTest.php
+index 671c2306..30906885 100644
+--- a/tests/VObject/Parser/MimeDirTest.php
++++ b/tests/VObject/Parser/MimeDirTest.php
+@@ -16,7 +16,7 @@ class MimeDirTest extends TestCase
+ public function testParseError()
+ {
+ $mimeDir = new MimeDir();
+- $mimeDir->parse(fopen(__FILE__, 'a'));
++ $mimeDir->parse(fopen(__FILE__, 'a+'));
+ }
+
+ public function testDecodeLatin1()
diff --git a/php-sabre-vobject4.spec b/php-sabre-vobject4.spec
index 8878d0f..8784d78 100644
--- a/php-sabre-vobject4.spec
+++ b/php-sabre-vobject4.spec
@@ -25,7 +25,7 @@
Name: php-sabre-vobject4
Summary: Library to parse and manipulate iCalendar and vCard objects
Version: 4.2.0
-Release: 2%{?dist}
+Release: 4%{?dist}
URL: http://sabre.io/vobject/
License: BSD
@@ -34,6 +34,7 @@ Source1: %{name}-autoload.php
# replace composer autloader
Patch0: %{name}-bin.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/sabre-io/vobject/pull/469.patch
BuildArch: noarch
%if %{with_tests}
@@ -102,6 +103,7 @@ Autoloader: %{_datadir}/php/Sabre/VObject4/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .pr469
cp %{SOURCE1} lib/autoload.php
@@ -155,6 +157,10 @@ exit $ret
%endif
%changelog
+* Mon Oct 9 2019 Remi Collet <remi@remirepo.net> - 4.2.0-4
+- add patch for PHP 7.4 from
+ https://github.com/sabre-io/vobject/pull/469
+
* Mon Jul 1 2019 Remi Collet <remi@remirepo.net> - 4.2.0-2
- fix autoloader for sabre/xml version 2