summaryrefslogtreecommitdiffstats
path: root/php-sabre-vobject.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sabre-vobject.spec')
-rw-r--r--php-sabre-vobject.spec41
1 files changed, 19 insertions, 22 deletions
diff --git a/php-sabre-vobject.spec b/php-sabre-vobject.spec
index 2f8f7d0..21ab7e9 100644
--- a/php-sabre-vobject.spec
+++ b/php-sabre-vobject.spec
@@ -8,8 +8,8 @@
#
%global gh_commit 129d80533a9ec0d9cacfb50b51180c34edb6874c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner fruux
-%global gh_project sabre-vobject
+%global gh_owner sabre-io
+%global gh_project vobject
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%if 0%{?fedora} > 25
@@ -18,21 +18,21 @@
%global with_cmd 1
%endif
-Name: php-%{gh_project}
+Name: php-sabre-vobject
Summary: Library to parse and manipulate iCalendar and vCard objects
Version: 3.5.3
-Release: 4%{?dist}
+Release: 7%{?dist}
URL: http://sabre.io/vobject/
License: BSD
Group: Development/Libraries
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
Source1: %{name}-autoload.php
# replace composer autloader
-Patch0: %{gh_project}-bin.patch
+Patch0: %{name}-bin.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/sabre-io/vobject/pull/395.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
@@ -82,6 +82,8 @@ Autoloader: %{_datadir}/php/Sabre/VObject/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1
+
cp %{SOURCE1} lib/autoload.php
@@ -110,21 +112,12 @@ cd tests
sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Skip upstream test suite
@@ -132,7 +125,6 @@ exit $ret
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
@@ -145,6 +137,11 @@ exit $ret
%changelog
+* Mon Oct 30 2017 Remi Collet <remi@remirepo.net> - 4.1.3-2
+- fix FTBFS fro mKoschei, add patch for test from
+ https://github.com/sabre-io/vobject/pull/395
+- sources from https://github.com/sabre-io/vobject/pull/395
+
* Tue Jan 17 2017 Remi Collet <remi@fedoraproject.org> - 3.5.3-4
- commands moved to php-sabre-vobject4 in F26