summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--395.patch2
-rw-r--r--469.patch22
-rw-r--r--c533d42e17e058237f0350ca56c7f01903bb035e.patch3
-rw-r--r--php-sabre-vobject.spec18
4 files changed, 37 insertions, 8 deletions
diff --git a/395.patch b/395.patch
index 0e6c5a7..7679502 100644
--- a/395.patch
+++ b/395.patch
@@ -11,7 +11,7 @@ diff --git a/lib/timezonedata/php-bc.php b/lib/timezonedata/php-bc.php
index 906ccb0e..83f38f50 100644
--- a/lib/timezonedata/php-bc.php
+++ b/lib/timezonedata/php-bc.php
-@@ -68,7 +68,6 @@
+@@ -67,7 +67,6 @@
'Brazil/West',
'Canada/Atlantic',
'Canada/Central',
diff --git a/469.patch b/469.patch
new file mode 100644
index 0000000..690edb3
--- /dev/null
+++ b/469.patch
@@ -0,0 +1,22 @@
+From 785981177a296b855d7318e87e095a0ea56f9715 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 9 Oct 2019 09:11:46 +0200
+Subject: [PATCH] fix Bad file descriptor (7.4)
+
+---
+ tests/VObject/Parser/MimeDirTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/VObject/Parser/MimeDirTest.php b/tests/VObject/Parser/MimeDirTest.php
+index 671c2306..30906885 100644
+--- a/tests/VObject/Parser/MimeDirTest.php
++++ b/tests/VObject/Parser/MimeDirTest.php
+@@ -14,7 +14,7 @@ class MimeDirTest extends \PHPUnit_Frame
+ function testParseError() {
+
+ $mimeDir = new MimeDir();
+- $mimeDir->parse(fopen(__FILE__,'a'));
++ $mimeDir->parse(fopen(__FILE__,'a+'));
+
+ }
+
diff --git a/c533d42e17e058237f0350ca56c7f01903bb035e.patch b/c533d42e17e058237f0350ca56c7f01903bb035e.patch
index 88cacc2..b3b8f34 100644
--- a/c533d42e17e058237f0350ca56c7f01903bb035e.patch
+++ b/c533d42e17e058237f0350ca56c7f01903bb035e.patch
@@ -18,7 +18,7 @@ diff --git a/lib/FreeBusyGenerator.php b/lib/FreeBusyGenerator.php
index e30b136c..ca77cb91 100644
--- a/lib/FreeBusyGenerator.php
+++ b/lib/FreeBusyGenerator.php
-@@ -430,7 +430,7 @@ protected function calculateBusy(FreeBusyData $fbData, array $objects) {
+@@ -212,7 +212,7 @@ protected function calculateBusy(FreeBusyData $fbData, array $objects) {
// instance. We are skipping this event from the output
// entirely.
unset($this->objects[$key]);
@@ -28,3 +28,4 @@ index e30b136c..ca77cb91 100644
if ($this->start) {
+
diff --git a/php-sabre-vobject.spec b/php-sabre-vobject.spec
index 7d521da..4079f7b 100644
--- a/php-sabre-vobject.spec
+++ b/php-sabre-vobject.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-sabre-vobject
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,7 +21,7 @@
Name: php-sabre-vobject
Summary: Library to parse and manipulate iCalendar and vCard objects
Version: 3.5.3
-Release: 10%{?dist}
+Release: 13%{?dist}
URL: http://sabre.io/vobject/
License: BSD
@@ -33,6 +33,7 @@ Patch0: %{name}-bin.patch
Patch1: https://patch-diff.githubusercontent.com/raw/sabre-io/vobject/pull/395.patch
# Adapted upstream patch
Patch2: c533d42e17e058237f0350ca56c7f01903bb035e.patch
+Patch3: https://patch-diff.githubusercontent.com/raw/sabre-io/vobject/pull/469.patch
BuildArch: noarch
%if %{with_tests}
@@ -85,6 +86,7 @@ Autoloader: %{_datadir}/php/Sabre/VObject/autoload.php
%patch0 -p1 -b .rpm
%patch1 -p1
%patch2 -p1
+%patch3 -p1 -b .pr469
cp %{SOURCE1} lib/autoload.php
@@ -115,7 +117,7 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php56 php70 php71 php72 php73; do
+for cmd in php php56 php70 php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -139,11 +141,15 @@ exit $ret
%changelog
-* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 4.1.3-10
+* Mon Oct 9 2019 Remi Collet <remi@remirepo.net> - 3.5.3-13
+- add patch for PHP 7.4 from
+ https://github.com/sabre-io/vobject/pull/469
+
+* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 3.5.3-10
- add adpated upstream patch for PHP 7.3
-* Mon Oct 30 2017 Remi Collet <remi@remirepo.net> - 4.1.3-2
-- fix FTBFS fro mKoschei, add patch for test from
+* Mon Oct 30 2017 Remi Collet <remi@remirepo.net> - 3.5.3-7
+- fix FTBFS from Koschei, add patch for test from
https://github.com/sabre-io/vobject/pull/395
- sources from https://github.com/sabre-io/vobject/pull/395