summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5eb5d74514230b11c80b67c7e147242757ccc660.patch43
-rw-r--r--php-sabre-dav.spec19
2 files changed, 57 insertions, 5 deletions
diff --git a/5eb5d74514230b11c80b67c7e147242757ccc660.patch b/5eb5d74514230b11c80b67c7e147242757ccc660.patch
new file mode 100644
index 0000000..d7c31f8
--- /dev/null
+++ b/5eb5d74514230b11c80b67c7e147242757ccc660.patch
@@ -0,0 +1,43 @@
+From 5eb5d74514230b11c80b67c7e147242757ccc660 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20M=C3=BCller?= <thomas.mueller@tmit.eu>
+Date: Wed, 26 Sep 2018 10:05:14 +0200
+Subject: [PATCH] Fix for php7.3 + adjusting PHPDoc
+
+---
+ lib/CalDAV/ICSExportPlugin.php | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/lib/CalDAV/ICSExportPlugin.php b/lib/CalDAV/ICSExportPlugin.php
+index eafb583620..6f84746cae 100644
+--- a/lib/CalDAV/ICSExportPlugin.php
++++ b/lib/CalDAV/ICSExportPlugin.php
+@@ -76,6 +76,9 @@ function initialize(DAV\Server $server) {
+ *
+ * @param RequestInterface $request
+ * @param ResponseInterface $response
++ * @throws BadRequest
++ * @throws DAV\Exception\NotFound
++ * @throws VObject\InvalidDataException
+ * @return bool
+ */
+ function httpGet(RequestInterface $request, ResponseInterface $response) {
+@@ -166,6 +169,8 @@ function httpGet(RequestInterface $request, ResponseInterface $response) {
+ * @param string $format
+ * @param array $properties
+ * @param ResponseInterface $response
++ * @throws DAV\Exception\NotFound
++ * @throws VObject\InvalidDataException
+ */
+ protected function generateResponse($path, $start, $end, $expand, $componentType, $format, $properties, ResponseInterface $response) {
+
+@@ -318,7 +323,9 @@ function mergeObjects(array $properties, array $inputObjects) {
+ // VTIMEZONE is special, because we need to filter out the duplicates
+ case 'VTIMEZONE' :
+ // Naively just checking tzid.
+- if (in_array((string)$child->TZID, $collectedTimezones)) continue;
++ if (in_array((string)$child->TZID, $collectedTimezones)) {
++ break;
++ }
+
+ $timezones[] = clone $child;
+ $collectedTimezones[] = $child->TZID;
diff --git a/php-sabre-dav.spec b/php-sabre-dav.spec
index 00bcc1d..f3abfd6 100644
--- a/php-sabre-dav.spec
+++ b/php-sabre-dav.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-sabre-dav
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit e987775e619728f12205606c9cc3ee565ffb1516
+%global gh_commit a9780ce4f35560ecbd0af524ad32d9d2c8954b80
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -18,8 +18,8 @@
Name: php-sabre-%{gh_project}
Summary: WebDAV Framework for PHP
-Version: 3.2.2
-Release: 5%{?dist}
+Version: 3.2.3
+Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
License: BSD
@@ -30,6 +30,8 @@ Source1: %{name}-autoload.php
Patch0: %{name}-autoload.patch
# For PHP 7.2
Patch1: https://patch-diff.githubusercontent.com/raw/fruux/sabre-dav/pull/1006.patch
+# For PHP 7.3
+Patch2: https://github.com/sabre-io/dav/commit/5eb5d74514230b11c80b67c7e147242757ccc660.patch
BuildArch: noarch
%if %{with_tests}
@@ -161,6 +163,7 @@ Autoloader: %{_datadir}/php/Sabre/DAV/autoload.php
%patch0 -p1 -b .rpm
%patch1 -p1
+%patch2 -p1
cp %{SOURCE1} lib/DAV/autoload.php
@@ -191,7 +194,7 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--filter '^((?!(testRequireAuth)).)*$' \
@@ -217,6 +220,12 @@ exit $ret
%changelog
+* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 3.2.3-1
+- update to 3.2.3
+
+* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 3.2.2-7
+- add upstream patch for PHP 7.3
+
* Tue Jun 5 2018 Remi Collet <remi@remirepo.net> - 3.2.2-5
- use range dependencies on F27+
- ignore 1 test failing with sabre/http 4.2.4