summaryrefslogtreecommitdiffstats
path: root/php-sabre-uri2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sabre-uri2.spec')
-rw-r--r--php-sabre-uri2.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php-sabre-uri2.spec b/php-sabre-uri2.spec
index 9dc98b4..c812a16 100644
--- a/php-sabre-uri2.spec
+++ b/php-sabre-uri2.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-sabre-uri2
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 18f454324f371cbcabdad3d0d3755b4b0182095d
+%global gh_commit 059d11012603be2e32ddb7543602965563ddbb09
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project uri
@@ -22,7 +22,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Functions for making sense out of URIs
-Version: 2.1.3
+Version: 2.2.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -33,18 +33,19 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 7
+BuildRequires: php(language) >= 7.1
# From composer.json, "require-dev": {
-# "phpunit/phpunit" : "^6"
+# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "phpunit/phpunit" : "^7 || ^8"
BuildRequires: php-pcre
-BuildRequires: phpunit6
+BuildRequires: phpunit8
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require" : {
-# "php": ">=7"
-Requires: php(language) > 7
+# "php": "^7.1"
+Requires: php(language) > 7.1
# From phpcompatinfo report for version 2.1.2
Requires: php-pcre
# Autoloader
@@ -101,10 +102,10 @@ mkdir vendor
ln -s %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php vendor/autoload.php
cd tests
-for cmd in php php71 php72 php73 php74
+for cmd in php php72 php73 php74
do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -124,6 +125,11 @@ exit $ret
%changelog
+* Sat Feb 1 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- raise dependency on PHP 7.1
+- switch to phpunit8
+
* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 2.1.3-1
- update to 2.1.3