summaryrefslogtreecommitdiffstats
path: root/php-robrichards-xmlseclibs3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-robrichards-xmlseclibs3.spec')
-rw-r--r--php-robrichards-xmlseclibs3.spec31
1 files changed, 17 insertions, 14 deletions
diff --git a/php-robrichards-xmlseclibs3.spec b/php-robrichards-xmlseclibs3.spec
index 127013e..01251ab 100644
--- a/php-robrichards-xmlseclibs3.spec
+++ b/php-robrichards-xmlseclibs3.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-robrichards-xmlseclibs3
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner robrichards
%global github_name xmlseclibs
-%global github_version 3.0.1
-%global github_commit d937712f70f93a584eb0299ccd87dc6374003781
+%global github_version 3.0.4
+%global github_commit 0a53d3c3aa87564910cae4ed01416441d3ae0db5
%global composer_vendor robrichards
%global composer_project xmlseclibs
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: A PHP library for XML Security (version 3)
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
@@ -46,22 +45,24 @@ BuildArch: noarch
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-## composer.json: optional
BuildRequires: php-openssl
-## phpcompatinfo (computed from version 3.0.1)
+## phpcompatinfo (computed from version 3.0.4)
BuildRequires: php-dom
+BuildRequires: php-filter
BuildRequires: php-hash
+BuildRequires: php-pcre
+BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-# composer.json: suggest
Requires: php-openssl
-# phpcompatinfo (computed from version 3.0.1)
+# phpcompatinfo (computed from version 3.0.4)
Requires: php-dom
Requires: php-hash
+Requires: php-pcre
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -108,15 +109,10 @@ sed 's#require.*xmlseclibs.*#require_once "%{buildroot}%{phpdir}/RobRichards/XML
: Skip tests known to fail
rm -f tests/extract-win-cert.phpt
-: Disable deprecation warning with php 7.1
-#for test in tests/*phpt; do
-# echo -e "\n--INI--\nerror_reporting=24575" >>$test
-#done
-
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" php70 php71 php72; do
+for PHP_EXEC in "" php70 php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose tests || RETURN_CODE=1
fi
@@ -138,6 +134,13 @@ exit $RETURN_CODE
%changelog
+* Wed Nov 06 2019 Shawn Iwinski <shawn@iwin.ski> - 3.0.4-1
+- Update to 3.0.4 (RHBZ #1769353 / CVE-2019-3465)
+- https://simplesamlphp.org/security/201911-01
+
+* Mon Nov 26 2018 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3
+
* Fri Sep 08 2017 Shawn Iwinski <shawn@iwin.ski> - 3.0.1-1
- Update to 3.0.1 (RHBZ #1487196)