summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-18 07:47:27 +0200
committerRemi Collet <remi@remirepo.net>2017-07-18 07:47:27 +0200
commit3fca45b81585257bcf027bde6e65efeddcf90b1c (patch)
treef6065d598c07b25299e347964584f1ced27f5d84
parentc15a3b0b37c925bb918f09b58cf8280e9b342380 (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json23
-rw-r--r--php-robrichards-xmlseclibs3.spec1
4 files changed, 35 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..5a81ccd
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,23 @@
+{
+ "name": "robrichards/xmlseclibs",
+ "description": "A PHP library for XML Security",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "xml",
+ "xmldsig",
+ "signature",
+ "security"
+ ],
+ "homepage": "https://github.com/robrichards/xmlseclibs",
+ "autoload": {
+ "psr-4": {
+ "RobRichards\\XMLSecLibs\\": "src"
+ }
+ },
+ "require": {
+ "php": ">= 5.6"
+ },
+ "suggest": {
+ "ext-openssl": "OpenSSL extension"
+ }
+}
diff --git a/php-robrichards-xmlseclibs3.spec b/php-robrichards-xmlseclibs3.spec
index 8d6c63a..1817e25 100644
--- a/php-robrichards-xmlseclibs3.spec
+++ b/php-robrichards-xmlseclibs3.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-robrichards-xmlseclibs3, from:
#
# Fedora spec file for php-robrichards-xmlseclibs3
#