summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-robrichards-xmlseclibs1.spec15
1 files changed, 11 insertions, 4 deletions
diff --git a/php-robrichards-xmlseclibs1.spec b/php-robrichards-xmlseclibs1.spec
index 6917042..40b1df9 100644
--- a/php-robrichards-xmlseclibs1.spec
+++ b/php-robrichards-xmlseclibs1.spec
@@ -28,7 +28,7 @@
Name: php-%{composer_vendor}-%{composer_project}1
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 2%{?github_release}%{?dist}
Summary: A PHP library for XML Security (version 1)
Group: Development/Libraries
@@ -111,15 +111,19 @@ sed 's#require.*xmlseclibs.*#require_once "%{buildroot}%{phpdir}/robrichards-xml
: Skip tests known to fail
rm -f tests/extract-win-cert.phpt
+: Disable deprecation warning with php 7.1
+for test in tests/*phpt; do
+ echo -e "\n--INI--\nerror_reporting=24575" >>$test
+done
+
: Run tests
run=0
if which php56; then
php56 %{_bindir}/phpunit tests
run=1
fi
-if which php70; then
- # use 7.0 as 7.1 have mcrypt deprecated
- php70 %{_bindir}/phpunit tests
+if which php71; then
+ php71 %{_bindir}/phpunit tests
run=1
fi
if [ $run -eq 0 ]; then
@@ -145,6 +149,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Nov 25 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-2
+- fix FTBFS, disable deprecation messages
+
* Thu Sep 8 2016 Remi Collet <remi@remirepo.net> - 1.4.2-1
- update to 1.4.2 (no change)