summaryrefslogtreecommitdiffstats
path: root/php-react-stream.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-stream.spec')
-rw-r--r--php-react-stream.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/php-react-stream.spec b/php-react-stream.spec
index ed89440..26dbd64 100644
--- a/php-react-stream.spec
+++ b/php-react-stream.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-stream
#
-# Copyright (c) 2017-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -44,7 +44,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
Summary: Basic readable and writable stream interfaces that support piping
License: MIT
@@ -55,6 +55,8 @@ URL: https://reactphp.org/stream/
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -116,6 +118,7 @@ Autoloader: %{phpdir}/React/Stream/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1
%build
@@ -162,7 +165,7 @@ rm -f tests/FunctionalInternetTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php72 php73 php74 php80; do
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -183,6 +186,9 @@ exit $RETURN_CODE
%changelog
+* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 1.1.1-5
+- fix FTBFS with PHP 8
+
* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 1.1.1-1
- Update to 1.1.1 (RHBZ #1830919)
- Use PHPUnit 7