summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-02 08:17:54 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-02 08:17:54 +0100
commitf065cc3c7f30d5483641bf856c05529bb9737feb (patch)
treecb9efe419c1b970257911e130a7387d7bf1bb3f5
parent8c1aad5b142e66a6996d35b5187530ab1b84830c (diff)
php-react-promise: Makefile
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed