summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 15:49:52 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 15:49:52 +0100
commitd693b1d7f305814b347c01f89936623b95aab679 (patch)
tree462835d96356a4c645d1d81baaa832b6587963ee
parent4cbd88f934ec29ef0fab30d0be3766d4cd0d42fd (diff)
v1.2.0 from Fedora
-rw-r--r--Makefile4
-rw-r--r--composer.json4
-rw-r--r--php-react-promise-stream.spec45
3 files changed, 26 insertions, 27 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
index d2aec73..7fe0bc3 100644
--- a/composer.json
+++ b/composer.json
@@ -19,13 +19,13 @@
},
"require": {
"php": ">=5.3",
- "react/stream": "^1.0 || ^0.7 || ^0.6 || ^0.5 || ^0.4 || ^0.3",
+ "react/stream": "^1.0 || ^0.7 || ^0.6 || ^0.5 || ^0.4.6",
"react/promise": "^2.1 || ^1.2"
},
"require-dev": {
"react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3",
"react/promise-timer": "^1.0",
"clue/block-react": "^1.0",
- "phpunit/phpunit": "^6.4 || ^5.7 || ^4.8.35"
+ "phpunit/phpunit": "^7.0 || ^6.4 || ^5.7 || ^4.8.35"
}
}
diff --git a/php-react-promise-stream.spec b/php-react-promise-stream.spec
index b487240..5730c60 100644
--- a/php-react-promise-stream.spec
+++ b/php-react-promise-stream.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise-stream
#
-# Copyright (c) 2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2018-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise-stream
-%global github_version 1.1.1
-%global github_commit 00e269d611e9c9a29356aef64c07f7e513e73dc9
+%global github_version 1.2.0
+%global github_commit 6384d8b76cf7dcc44b0bf3343fb2b2928412d1fe
%global composer_vendor react
%global composer_project promise-stream
@@ -32,25 +32,20 @@
# "react/promise-timer": "^1.0"
%global react_promise_timer_min_ver 1.0
%global react_promise_timer_max_ver 2.0
-# "react/stream": "^1.0 || ^0.7 || ^0.6 || ^0.5 || ^0.4 || ^0.3"
-%global react_stream_min_ver 0.3
+# "react/stream": "^1.0 || ^0.7 || ^0.6 || ^0.5 || ^0.4.6"
+%global react_stream_min_ver 0.4.6
%global react_stream_max_ver 2.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
-%if 0%{?fedora}
-%global with_phpunit6 1
-%endif
-
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: The missing link between Promise-land and Stream-land for ReactPHP
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -60,6 +55,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: phpunit7
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(clue/block-react) >= %{clue_block_react_min_ver} with php-composer(clue/block-react) < %{clue_block_react_max_ver})
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
@@ -78,12 +74,8 @@ BuildRequires: php-composer(react/promise) >= %{react_promise_min_ver}
BuildRequires: php-composer(react/stream) < %{react_stream_max_ver}
BuildRequires: php-composer(react/stream) >= %{react_stream_min_ver}
%endif
-### Dual PHPUnit stacks
-BuildRequires: php-composer(phpunit/phpunit)
-%if 0%{?with_phpunit6}
-BuildRequires: phpunit6
-%endif
-## phpcompatinfo for version 1.1.1
+## phpcompatinfo (computed from version 1.2.0)
+BuildRequires: php-reflection
BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -100,7 +92,7 @@ Requires: php-composer(react/promise) >= %{react_promise_min_ver}
Requires: php-composer(react/stream) < %{react_stream_max_ver}
Requires: php-composer(react/stream) >= %{react_stream_min_ver}
%endif
-# phpcompatinfo for version 1.1.1
+# phpcompatinfo (computed from version 1.2.0)
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -163,13 +155,12 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHPUNIT in phpunit %{?with_phpunit6:phpunit6}; do
- PHPUNIT=$(which $PHPUNIT)
- for PHP_EXEC in php %{?rhel:php54 php55 php56} php70 php71 php72; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
- fi
- done
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php71 php72 php73 php74; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
+ fi
done
exit $RETURN_CODE
%else
@@ -186,6 +177,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1.2.0-1
+- Update to 1.2.0 (RHBZ #1783720)
+- Use PHPUnit 7
+
* Sat Apr 21 2018 Shawn Iwinski <shawn@iwin.ski> - 1.1.1-2
- Add range version dependencies for Fedora >= 27 || RHEL >= 8