summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-26 14:55:02 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-26 14:55:02 +0100
commit5896c8186e5735ae2ace2d2ff85c9d58d2ad24f4 (patch)
tree83d898bddf417856601d5fd7ce94249c6ce502a5
parentb73dda55fb498fed89edc1a1e39709998c12869a (diff)
php-react-http: backport
-rw-r--r--Makefile4
-rw-r--r--composer.json18
-rw-r--r--php-react-http.spec4
3 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..c186927
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,18 @@
+{
+ "name": "react/http",
+ "description": "Library for building an evented http server.",
+ "keywords": ["http"],
+ "license": "MIT",
+ "require": {
+ "php": ">=5.4.0",
+ "guzzlehttp/psr7": "^1.0",
+ "react/socket": "^0.4",
+ "react/stream": "^0.4",
+ "evenement/evenement": "^2.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "React\\Http\\": "src"
+ }
+ }
+}
diff --git a/php-react-http.spec b/php-react-http.spec
index 4a5569c..9141ac8 100644
--- a/php-react-http.spec
+++ b/php-react-http.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-react-http, from:
#
# Fedora spec file for php-react-http
#
@@ -165,6 +166,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Thu Jan 26 2017 Remi Collet <remi@remirepo.net> - 0.4.2-2
+- backport
+
* Tue Jan 24 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.2-2
- Minor update to SCL tests (only php55 if rhel)