summaryrefslogtreecommitdiffstats
path: root/php-react-http-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-http-client.spec')
-rw-r--r--php-react-http-client.spec14
1 files changed, 11 insertions, 3 deletions
diff --git a/php-react-http-client.spec b/php-react-http-client.spec
index 66956eb..4522c81 100644
--- a/php-react-http-client.spec
+++ b/php-react-http-client.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-http-client
#
-# Copyright (c) 2017-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -59,7 +59,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 6%{?github_release}%{?dist}
+Release: 9%{?github_release}%{?dist}
Summary: Asynchronous HTTP client library
License: MIT
@@ -70,6 +70,10 @@ URL: https://reactphp.org/http-client/
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# minimal PHP 8 patch
+# not submitted upstream as dead project
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -149,6 +153,7 @@ Autoloader: %{phpdir}/React/HttpClient/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1
%build
@@ -200,7 +205,7 @@ rm -f tests/FunctionalIntegrationTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php72 php73 php74 php80; do
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -221,6 +226,9 @@ exit $RETURN_CODE
%changelog
+* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 0.5.10-9
+- fix FTBFS with PHP 8
+
* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 0.5.10-1
- Update to 0.5.10 (RHBZ #1791054)
- Use PHPUnit 7