summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--php-react-child-process.spec35
2 files changed, 25 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 59b088d..3e6a8fe 100644
--- a/composer.json
+++ b/composer.json
@@ -10,7 +10,8 @@
"react/stream": "^1.0 || ^0.7.6"
},
"require-dev": {
- "phpunit/phpunit": "^6.4 || ^5.7 || ^4.8.35",
+ "phpunit/phpunit": "^7.0 || ^6.4 || ^5.7 || ^4.8.35",
+ "react/socket": "^1.0",
"sebastian/environment": "^3.0 || ^2.0 || ^1.0"
},
"autoload": {
diff --git a/php-react-child-process.spec b/php-react-child-process.spec
index f562004..ba69bb7 100644
--- a/php-react-child-process.spec
+++ b/php-react-child-process.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-child-process
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name child-process
-%global github_version 0.5.2
-%global github_commit aae49d7f1340bafb695b9af3ce4421ea41a39620
+%global github_version 0.6.1
+%global github_commit 6895afa583d51dc10a4b9e93cd3bce17b3b77ac3
%global composer_vendor react
%global composer_project child-process
@@ -21,12 +21,14 @@
# "php": ">=5.3.0"
%global php_min_ver 5.3.0
# "evenement/evenement": "^3.0 || ^2.0 || ^1.0"
-# NOTE: Forced single major version
%global evenement_min_ver 2.0
-%global evenement_max_ver 3.0
+%global evenement_max_ver 4.0
# "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3.5"
%global react_event_loop_min_ver 0.3.5
%global react_event_loop_max_ver 2.0
+# "react/socket": "^1.0"
+%global react_socket_min_ver 1.0
+%global react_socket_max_ver 2.0
# "react/stream": "^1.0 || ^0.7.6"
%global react_stream_min_ver 0.7.6
%global react_stream_max_ver 2.0
@@ -44,7 +46,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Library for executing child processes
-Group: Development/Libraries
License: MIT
URL: https://reactphp.org/child-process/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -54,10 +55,11 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit7
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
+BuildRequires: (php-composer(react/socket) >= %{react_socket_min_ver} with php-composer(react/socket) < %{react_socket_max_ver})
BuildRequires: (php-composer(react/stream) >= %{react_stream_min_ver} with php-composer(react/stream) < %{react_stream_max_ver})
BuildRequires: (php-composer(sebastian/environment) >= %{sebastian_environment_min_ver} with php-composer(sebastian/environment) < %{sebastian_environment_max_ver})
%else
@@ -65,13 +67,16 @@ BuildRequires: php-composer(evenement/evenement) < %{evenement_max_ver}
BuildRequires: php-composer(evenement/evenement) >= %{evenement_min_ver}
BuildRequires: php-composer(react/event-loop) < %{react_event_loop_max_ver}
BuildRequires: php-composer(react/event-loop) >= %{react_event_loop_min_ver}
+BuildRequires: php-composer(react/socket) < %{react_socket_max_ver}
+BuildRequires: php-composer(react/socket) >= %{react_socket_min_ver}
BuildRequires: php-composer(react/stream) < %{react_stream_max_ver}
BuildRequires: php-composer(react/stream) >= %{react_stream_min_ver}
# use the one pulled by PHPUnit
#BuildRequires: php-composer(sebastian/environment) < %%{sebastian_environment_max_ver}
#BuildRequires: php-composer(sebastian/environment) >= %%{sebastian_environment_min_ver}
%endif
-## phpcompatinfo (computed from version 0.5.2)
+## phpcompatinfo (computed from version 0.6.1)
+BuildRequires: php-iconv
BuildRequires: php-pcntl
BuildRequires: php-spl
## Autoloader
@@ -92,7 +97,7 @@ Requires: php-composer(react/event-loop) >= %{react_event_loop_min_ver}
Requires: php-composer(react/stream) < %{react_stream_max_ver}
Requires: php-composer(react/stream) >= %{react_stream_min_ver}
%endif
-# phpcompatinfo (computed from version 0.5.2)
+# phpcompatinfo (computed from version 0.6.1)
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -145,6 +150,7 @@ require '%{buildroot}%{phpdir}/React/ChildProcess/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('React\\Tests\\ChildProcess\\', __DIR__.'/tests');
\Fedora\Autoloader\Dependencies::required(array(
+ '%{phpdir}/React/Socket/autoload.php',
array(
'%{phpdir}/SebastianBergmann/Environment3/autoload.php',
'%{phpdir}/SebastianBergmann/Environment2/autoload.php',
@@ -159,9 +165,10 @@ sed 's/function testProcessPidNotSameDueToShellWrapper/function SKIP_testProcess
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php54 php55 php56} php70 php71 php72 php73; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php71 php72 php73 php74; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -180,6 +187,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 0.6.1-1
+- Update to 0.6.1 (RHBZ #1677881)
+- Use PHPUnit 7
+
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.2-1
- Update to 0.5.2 (RHBZ #1482155)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8