summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-25 07:12:28 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-25 07:12:28 +0100
commit3a1058d83242594016ab9d03e5f9fff10549c523 (patch)
treedbe20c6a01c39e3119330fe9e79f79a2eb721cac
parente93265b19a8f524d7e531c6e491d770cb6d689b6 (diff)
php-react-child-process: backport
-rw-r--r--Makefile4
-rw-r--r--composer.json18
-rw-r--r--php-react-child-process.spec6
3 files changed, 27 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..145e914
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,18 @@
+{
+ "name": "react/child-process",
+ "description": "Library for executing child processes.",
+ "keywords": ["process"],
+ "license": "MIT",
+ "require": {
+ "php": ">=5.4.0",
+ "evenement/evenement": "~2.0",
+ "react/event-loop": "0.4.*",
+ "react/stream": "~0.4.2"
+ },
+ "require-dev": {
+ "sebastian/environment": "~1.0"
+ },
+ "autoload": {
+ "psr-4": { "React\\ChildProcess\\": "src" }
+ }
+}
diff --git a/php-react-child-process.spec b/php-react-child-process.spec
index 152d5a8..1900bcf 100644
--- a/php-react-child-process.spec
+++ b/php-react-child-process.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-react-child-process, from:
#
# Fedora spec file for php-react-child-process
#
@@ -29,7 +30,7 @@
%global react_stream_min_ver 0.4.2
%global react_stream_max_ver 0.5.0
# "sebastian/environment": "~1.0"
-%if 0%{?el7}
+%if 0
%global sebastian_environment_min_ver 1.0
%global sebastian_environment_max_ver 2.0
%else
@@ -167,6 +168,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Wed Jan 25 2017 Remi Collet <remi@remirepo.net> - 1.1.0-2
+- backport for remi repo
+
* Tue Jan 24 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.1-2
- Retrict sebastian/environment dependency to one major version
- Minor update to SCL tests (only php55 if rhel)