summaryrefslogtreecommitdiffstats
path: root/php-ramsey-uuid.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ramsey-uuid.spec')
-rw-r--r--php-ramsey-uuid.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index d434497..98f7150 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -23,7 +23,7 @@
Name: php-%{pk_vendor}-%{pk_name}
Version: 4.3.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Library for generating and working with UUIDs
License: MIT
@@ -65,7 +65,7 @@ BuildRequires: php-spl
%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
+BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 1)
BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
@@ -93,7 +93,7 @@ Requires: php-ctype
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
+Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 1)
Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
# remirepo:4
%else
@@ -161,14 +161,16 @@ EOF
: Ignore tests using missing mocking libraries
find tests -type f -exec grep -Eq '(PHPMockery|Aspec|Moontoast)' {} \; -delete -print
-: Ignore test with erratic result on Koji
-FILTER="--filter '^((?!(testSerializationOfNodeProviderCollection)).)*$'"
+: Ignore tests
+# testSerializationOfNodeProviderCollection: erratic result on Koji
+# testGetLocalDomainAndIdentifier: https://github.com/ramsey/uuid/issues/425
+FILTER="--filter '^((?!(testSerializationOfNodeProviderCollection|testGetLocalDomainAndIdentifier)).)*$'"
: Test failing with recent depdencies
rm tests/Generator/RandomLibAdapterTest.php
: Run upstream test suite
ret=0
-for cmdarg in "php %{?phpunit}" php80 php81; do
+for cmdarg in "php %{?phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -191,6 +193,9 @@ exit $ret
%changelog
+* Mon Jun 20 2022 Remi Collet <remi@remirepo.net> - 4.3.1-2
+- allow brick/math 0.10
+
* Mon Mar 28 2022 Remi Collet <remi@remirepo.net> - 4.3.1-1
- update to 4.3.1
- raise dependency on PHP 8.0