summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-19 08:52:22 +0100
committerRemi Collet <remi@remirepo.net>2019-12-19 08:52:22 +0100
commit27bd194c16ca15dca2f453c4a8af5f372f740472 (patch)
treeb315a23b8bb05f8ca1e6695b44bdabe72390bd0a
import from Fedora
-rw-r--r--composer.json26
-rwxr-xr-xphp-ralouphie-getallheaders-get-source.sh73
-rw-r--r--php-ralouphie-getallheaders.spec115
3 files changed, 214 insertions, 0 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..de8ce62
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,26 @@
+{
+ "name": "ralouphie/getallheaders",
+ "description": "A polyfill for getallheaders.",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Ralph Khattar",
+ "email": "ralph.khattar@gmail.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.6"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5 || ^6.5",
+ "php-coveralls/php-coveralls": "^2.1"
+ },
+ "autoload": {
+ "files": ["src/getallheaders.php"]
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "getallheaders\\Tests\\": "tests/"
+ }
+ }
+}
diff --git a/php-ralouphie-getallheaders-get-source.sh b/php-ralouphie-getallheaders-get-source.sh
new file mode 100755
index 0000000..b2ac62b
--- /dev/null
+++ b/php-ralouphie-getallheaders-get-source.sh
@@ -0,0 +1,73 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-ralouphie-getallheaders.spec b/php-ralouphie-getallheaders.spec
new file mode 100644
index 0000000..6f0fa5c
--- /dev/null
+++ b/php-ralouphie-getallheaders.spec
@@ -0,0 +1,115 @@
+#
+# Fedora spec file for php-ralouphie-getallheaders
+#
+# Copyright (c) 2019 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner ralouphie
+%global github_name getallheaders
+%global github_version 3.0.3
+%global github_commit 120b605dfeb996808c31b6477290a714d356e822
+
+%global composer_vendor ralouphie
+%global composer_project getallheaders
+
+# "php": ">=5.6"
+%global php_min_ver 5.6
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: A polyfill for getallheaders
+
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-ralouphie-getallheaders-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: phpunit6
+## phpcompatinfo for version 3.0.3
+## <none>
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo for version 3.0.3
+# <none>
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+%{summary}.
+
+https://www.php.net/manual/function.getallheaders.php
+
+Autoloader: %{phpdir}/%{composer_vendor}-%{composer_project}/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Common autoloader
+ln -s getallheaders.php src/autoload.php
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp src %{buildroot}%{phpdir}/%{composer_vendor}-%{composer_project}
+
+
+%check
+%if %{with_tests}
+: Mock Composer autoloader
+mkdir vendor
+ln -s %{buildroot}%{phpdir}/%{composer_vendor}-%{composer_project}/autoload.php vendor/autoload.php
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit6)
+for PHP_EXEC in php php70 php71 php72 php73 php74; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{phpdir}/%{composer_vendor}-%{composer_project}
+
+
+%changelog
+* Mon Dec 16 2019 Shawn Iwinski <shawn@iwin.ski> - 3.0.3-1
+- Update to 3.0.3
+- Use PHPUnit 6
+
+* Sun Dec 01 2019 Shawn Iwinski <shawn@iwin.ski> - 2.0.5-1
+- Initial package