summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--php-psr-http-message.spec10
2 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-psr-http-message.spec b/php-psr-http-message.spec
index 5bc5460..2cdbc95 100644
--- a/php-psr-http-message.spec
+++ b/php-psr-http-message.spec
@@ -30,6 +30,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
# phpcompatinfo (computed from version 0.4.0)
Requires: php(language) >= 5.3.0
@@ -59,6 +60,7 @@ chmod a-x README.md composer.json LICENSE
%install
+rm -rf %{buildroot}
mkdir -pm 0755 %{buildroot}%{phpdir}/Psr/Http/Message
cp -rp src/* %{buildroot}%{phpdir}/Psr/Http/Message/
@@ -67,7 +69,12 @@ cp -rp src/* %{buildroot}%{phpdir}/Psr/Http/Message/
# No tests provided by upstream
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
@@ -77,5 +84,8 @@ cp -rp src/* %{buildroot}%{phpdir}/Psr/Http/Message/
%changelog
+* Thu Nov 6 2014 Remi Collet <remi@fedoraproject.org> - 0.4.0-1
+- backport for remi repository
+
* Thu Oct 30 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.4.0-1
- Initial package