summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-01 16:22:28 +0200
committerRemi Collet <remi@remirepo.net>2021-04-01 16:22:28 +0200
commiteeaea7f0803ff9e871d0802ab9a7cad5ef55fe81 (patch)
tree791156ac131020852c90f20515856235b5f32616
duplicate v5
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json41
-rw-r--r--php-pragmarx-google2fa8.spec187
4 files changed, 241 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..a24231f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,41 @@
+{
+ "name": "pragmarx/google2fa",
+ "description": "A One Time Password Authentication package, compatible with Google Authenticator.",
+ "keywords": [
+ "authentication",
+ "two factor authentication",
+ "google2fa",
+ "2fa"
+ ],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Antonio Carlos Ribeiro",
+ "email": "acr@antoniocarlosribeiro.com",
+ "role": "Creator & Designer"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "paragonie/constant_time_encoding": "~1.0|~2.0",
+ "paragonie/random_compat": ">=1",
+ "symfony/polyfill-php56": "~1.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4|~5|~6"
+ },
+ "autoload": {
+ "psr-4": {
+ "PragmaRX\\Google2FA\\": "src/",
+ "PragmaRX\\Google2FA\\Tests\\": "tests/"
+ }
+ },
+ "extra": {
+ "component": "package",
+ "branch-alias": {
+ "dev-master": "2.0-dev"
+ }
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true
+}
diff --git a/php-pragmarx-google2fa8.spec b/php-pragmarx-google2fa8.spec
new file mode 100644
index 0000000..7d9c99a
--- /dev/null
+++ b/php-pragmarx-google2fa8.spec
@@ -0,0 +1,187 @@
+# remirepo/fedora spec file for php-pragmarx-google2fa5
+#
+# Copyright (c) 2018-2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%global with_tests 0%{!?_without_tests:1}
+# Github
+%global gh_commit 17c969c82f427dd916afe4be50bafc6299aef1b4
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner antonioribeiro
+%global gh_project google2fa
+# Packagist
+%global pk_vendor pragmarx
+%global pk_project %{gh_project}
+# Namespace
+%global ns_vendor PragmaRX
+%global ns_project Google2FA
+%global major 5
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 5.0.0
+Release: 5%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Summary: Google Two-Factor Authentication for PHP Package
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(paragonie/constant_time_encoding) >= 1.0 with php-composer(paragonie/constant_time_encoding) < 3)
+BuildRequires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
+# remirepo:4
+%else
+BuildRequires: php-paragonie-constant-time-encoding
+BuildRequires: php-paragonie-random-compat
+%endif
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-pcre
+# For tests, from composer.json "require-dev": {
+# "phpunit/phpunit": "~4|~5|~6"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit7
+# remirepo:4
+%else
+BuildRequires: php-composer(phpunit/phpunit)
+%global phpunit %{_bindir}/phpunit
+%endif
+# For autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.4",
+# "paragonie/constant_time_encoding": "~1.0|~2.0",
+# "paragonie/random_compat": ">=1",
+# "symfony/polyfill-php56": "~1.2"
+# Use 5.6 and avoid polyfill
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# Only use constant_time_encoding v1 available in Fedora for autoloader path
+Requires: (php-composer(paragonie/constant_time_encoding) >= 1.0 with php-composer(paragonie/constant_time_encoding) < 3)
+# Only use random_compat v2 available in Fedora for autoloader path
+Requires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
+# remirepo:4
+%else
+Requires: php-paragonie-constant-time-encoding
+Requires: php-paragonie-random-compat
+%endif
+# From phpcompatinfo report for 5.0.0
+Requires: php-hash
+Requires: php-pcre
+# For generated autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Google2FA is a PHP implementation of the Google Two-Factor Authentication
+Module, supporting the HMAC-Based One-time Password (HOTP) algorithm
+specified in RFC 4226 and the Time-based One-time Password (TOTP) algorithm
+specified in RFC 6238.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/ParagonIE/ConstantTime/autoload.php',
+ '%{_datadir}/php/random_compat/autoload.php',
+]);
+AUTOLOAD
+
+
+%build
+: Nothing to build
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\Tests\\', dirname(__DIR__).'/tests');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md RELICENSED.md
+%doc composer.json
+%doc README.md changelog.md
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 5.0.0-5
+- switch to phpunit7
+
+* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- rename to php-pragmarx-google2fa5
+- move to /usr/share/php/PragmaRX/Google2FA5
+- drop dependency on bacon/bacon-qr-code
+
+* Wed Aug 29 2018 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3 (no change)
+
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2 (no change)
+
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.0.1-2
+- allow paragonie/constant_time_encoding v2
+
+* Thu Mar 22 2018 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+- license have be changed to MIT
+
+* Wed Mar 7 2018 Remi Collet <remi@remirepo.net> - 2.0.7-2
+- add GPLv3+ to License field and ask upstream for clarification
+ https://github.com/antonioribeiro/google2fa/issues/95
+
+* Wed Mar 7 2018 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- initial package