summaryrefslogtreecommitdiffstats
path: root/php-pragmarx-google2fa5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pragmarx-google2fa5.spec')
-rw-r--r--php-pragmarx-google2fa5.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-pragmarx-google2fa5.spec b/php-pragmarx-google2fa5.spec
index 73046aa..7d9c99a 100644
--- a/php-pragmarx-google2fa5.spec
+++ b/php-pragmarx-google2fa5.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-pragmarx-google2fa5
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,7 +23,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 5.0.0
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Release: 5%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Google Two-Factor Authentication for PHP Package
License: MIT
@@ -49,8 +49,8 @@ BuildRequires: php-pcre
# "phpunit/phpunit": "~4|~5|~6"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit6
-%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit7
# remirepo:4
%else
BuildRequires: php-composer(phpunit/phpunit)
@@ -134,10 +134,10 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -157,6 +157,9 @@ exit $ret
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 5.0.0-5
+- switch to phpunit7
+
* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- rename to php-pragmarx-google2fa5