summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-traits.json2
-rw-r--r--php-phpunitgoodpractices-polyfill.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer-traits.json b/composer-traits.json
index 8a097e5..61e28cc 100644
--- a/composer-traits.json
+++ b/composer-traits.json
@@ -11,7 +11,7 @@
],
"require": {
"php": "^5.5 || ^7.0",
- "phpunit/phpunit": "~4.0.0 || ~4.1.0 || ~4.2.0 || ~4.3.0 || ~4.4.0 || ~4.5.0 || ~4.6.0 || ~4.8.0 || ~5.3.0 || ~5.4.0 || ~5.5.0 || ~5.6.0 || ~5.7.0 || ~6.0.0 || ~6.1.0 || ~6.2.0 || ~6.3.0 || ~6.4.0 || ~6.5.0 || ~7.0.0 || ~7.1.0 || ~7.2.6 || ~7.3.0"
+ "phpunit/phpunit": "~4.0.0 || ~4.1.0 || ~4.2.0 || ~4.3.0 || ~4.4.0 || ~4.5.0 || ~4.6.0 || ~4.8.0 || ~5.3.0 || ~5.4.0 || ~5.5.0 || ~5.6.0 || ~5.7.0 || ~6.0.0 || ~6.1.0 || ~6.2.0 || ~6.3.0 || ~6.4.0 || ~6.5.0 || ~7.0.0 || ~7.1.0 || ~7.2.6 || ~7.3.0 || ~7.4.0 || ~7.5.0"
},
"require-dev": {
"phpunitgoodpractices/polyfill": "^1.1"
diff --git a/php-phpunitgoodpractices-polyfill.spec b/php-phpunitgoodpractices-polyfill.spec
index 26a179d..5ca0279 100644
--- a/php-phpunitgoodpractices-polyfill.spec
+++ b/php-phpunitgoodpractices-polyfill.spec
@@ -21,13 +21,13 @@
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
# Traits
-%global tr_commit d3d74de03f733d0b6afb7734f48d944ee65cf83c
+%global tr_commit d7864f7d8eb9ee2e84eebc45baf3eace73ce2c4b
%global tr_short %(c=%{tr_commit}; echo ${c:0:7})
-%global tr_version 1.6.0
+%global tr_version 1.7.0
Name: php-%{pk_vendor}-%{pk_project}
Version: 1.1.0
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: Lacking future-compat polyfills for PHPUnit
Group: Development/Tools
@@ -51,7 +51,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": "^5.5 || ^7.0",
-# "phpunit/phpunit": "^4.0 || ^5.3 || ^6.0 || ^7.0"
+# "phpunit/phpunit": ""~4.0.0 || ~4.1.0 || ~4.2.0 || ~4.3.0 || ~4.4.0 || ~4.5.0 || ~4.6.0 || ~4.8.0 || ~5.3.0 || ~5.4.0 || ~5.5.0 || ~5.6.0 || ~5.7.0 || ~6.0.0 || ~6.1.0 || ~6.2.0 || ~6.3.0 || ~6.4.0 || ~6.5.0 || ~7.0.0 || ~7.1.0 || ~7.2.6 || ~7.3.0 || ~7.4.0 || ~7.5.0"
Requires: php(language) >= 5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -65,9 +65,9 @@ Requires: php-phpunit-PHPUnit
# Autoloader
Requires: php-composer(fedora/autoloader)
-Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
Provides: php-%{pk_vendor}-traits = %{tr_version}
Provides: php-composer(%{pk_vendor}/traits) = %{tr_version}
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
@@ -146,6 +146,9 @@ if (!class_exists("PHPUnitGoodPractices\\Traits\\PHPUnitVersionRetriever")) {
%changelog
+* Sat Dec 29 2018 Remi Collet <remi@remirepo.net> - 1.1.0-5
+- update phpunitgoodpractices/traits to 1.7.0
+
* Tue Sep 4 2018 Remi Collet <remi@remirepo.net> - 1.1.0-4
- update phpunitgoodpractices/traits to 1.6.0