summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-traits.json2
-rw-r--r--php-phpunitgoodpractices-polyfill.spec9
2 files changed, 7 insertions, 4 deletions
diff --git a/composer-traits.json b/composer-traits.json
index 4275245..8a097e5 100644
--- a/composer-traits.json
+++ b/composer-traits.json
@@ -11,7 +11,7 @@
],
"require": {
"php": "^5.5 || ^7.0",
- "phpunit/phpunit": "~4.0.0 || ~4.1.0 || ~4.2.0 || ~4.3.0 || ~4.4.0 || ~4.5.0 || ~4.6.0 || ~4.8.0 || ~5.3.0 || ~5.4.0 || ~5.5.0 || ~5.6.0 || ~5.7.0 || ~6.0.0 || ~6.1.0 || ~6.2.0 || ~6.3.0 || ~6.4.0 || ~6.5.0 || ~7.0.0 || ~7.1.0 || ~7.2.6"
+ "phpunit/phpunit": "~4.0.0 || ~4.1.0 || ~4.2.0 || ~4.3.0 || ~4.4.0 || ~4.5.0 || ~4.6.0 || ~4.8.0 || ~5.3.0 || ~5.4.0 || ~5.5.0 || ~5.6.0 || ~5.7.0 || ~6.0.0 || ~6.1.0 || ~6.2.0 || ~6.3.0 || ~6.4.0 || ~6.5.0 || ~7.0.0 || ~7.1.0 || ~7.2.6 || ~7.3.0"
},
"require-dev": {
"phpunitgoodpractices/polyfill": "^1.1"
diff --git a/php-phpunitgoodpractices-polyfill.spec b/php-phpunitgoodpractices-polyfill.spec
index d930443..26a179d 100644
--- a/php-phpunitgoodpractices-polyfill.spec
+++ b/php-phpunitgoodpractices-polyfill.spec
@@ -21,13 +21,13 @@
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
# Traits
-%global tr_commit 10d22ad5e222b5e5eae6941aac91c068397b5127
+%global tr_commit d3d74de03f733d0b6afb7734f48d944ee65cf83c
%global tr_short %(c=%{tr_commit}; echo ${c:0:7})
-%global tr_version 1.5.1
+%global tr_version 1.6.0
Name: php-%{pk_vendor}-%{pk_project}
Version: 1.1.0
-Release: 2%{?dist}
+Release: 4%{?dist}
Summary: Lacking future-compat polyfills for PHPUnit
Group: Development/Tools
@@ -146,6 +146,9 @@ if (!class_exists("PHPUnitGoodPractices\\Traits\\PHPUnitVersionRetriever")) {
%changelog
+* Tue Sep 4 2018 Remi Collet <remi@remirepo.net> - 1.1.0-4
+- update phpunitgoodpractices/traits to 1.6.0
+
* Mon Jun 25 2018 Remi Collet <remi@remirepo.net> - 1.1.0-2
- add mandatory dependency on one PHPUnit version
- add phpunitgoodpractices/traits 1.5.1