summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-07 07:23:11 +0200
committerRemi Collet <remi@remirepo.net>2021-06-07 07:23:11 +0200
commit8f94141db0f49cb5f402c09aa5474f4fc8ba5465 (patch)
tree583a8db6571131127c2b974ba4656e19badec6ff
parent945d560e0392fda8b814826e97fef0c6e3b1eb96 (diff)
update to 9.5.5HEADmaster
raise dependency on sebastian/type 2.3.2
-rw-r--r--composer.json2
-rw-r--r--phpunit9-rpm.patch29
-rw-r--r--phpunit9.spec18
3 files changed, 30 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index fd6461f..81b1fd2 100644
--- a/composer.json
+++ b/composer.json
@@ -47,7 +47,7 @@
"sebastian/global-state": "^5.0.1",
"sebastian/object-enumerator": "^4.0.3",
"sebastian/resource-operations": "^3.0.3",
- "sebastian/type": "^2.3",
+ "sebastian/type": "^2.3.2",
"sebastian/version": "^3.0.2"
},
"require-dev": {
diff --git a/phpunit9-rpm.patch b/phpunit9-rpm.patch
index b6ccbc5..d3c313b 100644
--- a/phpunit9-rpm.patch
+++ b/phpunit9-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2020-08-10 12:02:07.000000000 +0200
-+++ ./phpunit 2020-08-10 12:02:22.089870229 +0200
+--- ./phpunit.rpm 2021-06-07 07:17:56.000000000 +0200
++++ ./phpunit 2021-06-07 07:18:25.769837276 +0200
@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -44,8 +44,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
---- ./src/Util/Xml/SchemaFinder.php.rpm 2020-08-10 12:02:22.089870229 +0200
-+++ ./src/Util/Xml/SchemaFinder.php 2020-08-10 12:06:11.098559995 +0200
+--- ./src/Util/Xml/SchemaFinder.php.rpm 2021-06-07 07:17:56.000000000 +0200
++++ ./src/Util/Xml/SchemaFinder.php 2021-06-07 07:18:25.769837276 +0200
@@ -48,6 +48,6 @@ final class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -55,14 +55,21 @@ diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2020-08-10 12:02:07.000000000 +0200
-+++ ./tests/bootstrap.php 2020-08-10 12:02:22.089870229 +0200
-@@ -14,4 +14,8 @@ if (!\defined('TEST_FILES_PATH')) {
- \ini_set('precision', '14');
- \ini_set('serialize_precision', '14');
+--- ./tests/bootstrap.php.rpm 2021-06-07 07:18:25.769837276 +0200
++++ ./tests/bootstrap.php 2021-06-07 07:19:32.888583752 +0200
+@@ -8,7 +8,7 @@
+ * file that was distributed with this source code.
+ */
+ if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
+- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
++ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
+ }
+
+ if (!defined('TEST_FILES_PATH')) {
+@@ -19,3 +19,7 @@ ini_set('precision', '14');
+ ini_set('serialize_precision', '14');
--require_once __DIR__ . '/../vendor/autoload.php';
-+require_once '@PATH@/autoload.php';
+ require_once PHPUNIT_COMPOSER_INSTALL;
+require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
+require_once __DIR__ . '/_files/CoveredFunction.php';
+require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
diff --git a/phpunit9.spec b/phpunit9.spec
index 67cf084..9b6f7e0 100644
--- a/phpunit9.spec
+++ b/phpunit9.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c73c6737305e779771147af66c96ca6a7ed8a741
+%global gh_commit 89ff45ea9d70e35522fb6654a2ebc221158de276
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
%global ver_minor 5
-%global upstream_version 9.5.4
+%global upstream_version 9.5.5
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -64,7 +64,7 @@ BuildRequires: (php-composer(sebastian/exporter) >= 4.0.2 with php-c
BuildRequires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
BuildRequires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-BuildRequires: (php-composer(sebastian/type) >= 2.3 with php-composer(sebastian/type) < 3)
+BuildRequires: (php-composer(sebastian/type) >= 2.3.2 with php-composer(sebastian/type) < 3)
BuildRequires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# remirepo:23
%else
@@ -87,7 +87,7 @@ BuildRequires: php-sebastian-exporter4 >= 4.0.2
BuildRequires: php-sebastian-global-state5 >= 5.0
BuildRequires: php-sebastian-object-enumerator4 >= 4.0.2
BuildRequires: php-sebastian-resource-operations3 >= 3.0.2
-BuildRequires: php-sebastian-type2 >= 2.3
+BuildRequires: php-sebastian-type2 >= 2.3.2
BuildRequires: php-sebastian-version3 >= 3.0.1
%endif
BuildRequires: php-dom
@@ -126,7 +126,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/global-state": "^5.0.1",
# "sebastian/object-enumerator": "^4.0.3",
# "sebastian/resource-operations": "^3.0.3",
-# "sebastian/type": "^2.3",
+# "sebastian/type": "^2.3.2",
# "sebastian/version": "^3.0.2"
Requires: php(language) >= 7.3
Requires: php-cli
@@ -157,7 +157,7 @@ Requires: (php-composer(sebastian/exporter) >= 4.0.2 with php-c
Requires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
Requires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
Requires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-Requires: (php-composer(sebastian/type) >= 2.3 with php-composer(sebastian/type) < 3)
+Requires: (php-composer(sebastian/type) >= 2.3.2 with php-composer(sebastian/type) < 3)
Requires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# From composer.json, "suggest": {
# "ext-soap": "*",
@@ -185,7 +185,7 @@ Requires: php-sebastian-exporter4 >= 4.0.2
Requires: php-sebastian-global-state5 >= 5.0
Requires: php-sebastian-object-enumerator4 >= 4.0.2
Requires: php-sebastian-resource-operations3 >= 3.0.2
-Requires: php-sebastian-type2 >= 2.3
+Requires: php-sebastian-type2 >= 2.3.2
Requires: php-sebastian-version3 >= 3.0.1
%endif
# Autoloader
@@ -303,6 +303,10 @@ exit $ret
%changelog
+* Mon Jun 7 2021 Remi Collet <remi@remirepo.net> - 9.5.5-1
+- update to 9.5.5
+- raise dependency on sebastian/type 2.3.2
+
* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 9.5.4-1
- update to 9.5.4