summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh36
-rw-r--r--phpunit8.spec16
2 files changed, 31 insertions, 21 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 8152336..3580b58 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,28 +1,32 @@
#!/bin/bash
NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_vendor/{s/.* //;p}' $NAME.spec)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
+ echo "$NAME-$VERSION-$SHORT.tgz already there"
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-echo "Cloning..."
-rm -rf $PROJECT-$COMMIT
-git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+ echo "Cloning..."
+ rm -rf $PROJECT-$COMMIT
+ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-git checkout $COMMIT
-cp composer.json ../composer.json
-popd
+ echo "Getting commit..."
+ pushd $PROJECT-$COMMIT
+ git checkout $COMMIT || exit1
+ cp composer.json ../composer.json
+ popd
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+ echo "Archiving..."
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
+ echo "Cleaning..."
+ rm -rf $PROJECT-$COMMIT
-echo "Done."
+ echo "Done."
+fi
diff --git a/phpunit8.spec b/phpunit8.spec
index f747ccb..be85f1f 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -11,10 +11,10 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c25f79895d27b6ecd5abfa63de1606b786a461a3
+%global gh_commit 038d4196d8e8cb405cd5e82cedfe413ad6eef9ef
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_vendor sebastianbergmann
+%global gh_owner sebastianbergmann
%global gh_project phpunit
# Packagist
%global pk_vendor phpunit
@@ -26,14 +26,17 @@
%global ver_minor 5
%global specrel 1
+%global upstream_version 8.5.15
+#global upstream_prever dev
+
Name: %{pk_project}%{ver_major}
-Version: 8.5.14
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD
-URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: %{name}-%{version}-%{gh_short}.tgz
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{upstream_version}-%{gh_short}.tgz
Source1: makesrc.sh
# Fix command for autoload
@@ -281,6 +284,9 @@ exit $ret
%changelog
+* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 8.5.15-1
+- update to 8.5.15
+
* Wed Feb 3 2021 Remi Collet <remi@remirepo.net> - 8.5.14-1
- update to 8.5.14