summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-23 07:22:08 +0200
committerRemi Collet <remi@remirepo.net>2020-05-23 07:22:08 +0200
commitc0e0aebf2d103dbf3daff61d8c3799fe87f6c722 (patch)
treec60349893fbd279a9874bc6632e6cf32382a41be
parentc62167e9a423ad303e3d8a73c9dc29ba3ab47869 (diff)
update to 8.5.5
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--phpunit8.spec12
2 files changed, 36 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..8152336
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_vendor/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/phpunit8.spec b/phpunit8.spec
index 614cc5e..c2c71c8 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 8474e22d7d642f665084ba5ec780626cbd1efd23
+%global gh_commit 63dda3b212a0025d380a745f91bdb4d8c985adb7
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,17 +24,17 @@
%global php_home %{_datadir}/php
%global ver_major 8
%global ver_minor 5
-%global ver_patch 4
%global specrel 1
Name: %{pk_project}%{ver_major}
-Version: %{ver_major}.%{ver_minor}.%{ver_patch}
+Version: 8.5.5
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD
URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
# Fix command for autoload
Patch0: %{name}-rpm.patch
@@ -287,6 +287,10 @@ exit $ret
%changelog
+* Sat May 23 2020 Remi Collet <remi@remirepo.net> - 8.5.5-1
+- update to 8.5.5
+- sources from git snapshot
+
* Thu Apr 23 2020 Remi Collet <remi@remirepo.net> - 8.5.4-1
- update to 8.5.4