summaryrefslogtreecommitdiffstats
path: root/phpunit10.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phpunit10.spec')
-rw-r--r--phpunit10.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/phpunit10.spec b/phpunit10.spec
index 5a1658c..9f26878 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit aa0a8ce701ea7ee314b0dfaa8970dc94f3f8c870
-%global gh_date 2024-10-08
+%global gh_commit c7cffa0efa2b70c22366523e6d804c9419eb2400
+%global gh_date 2024-10-21
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 10
%global ver_minor 5
-%global upstream_version 10.5.36
+%global upstream_version 10.5.37
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -63,7 +63,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 3.0.1 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 6.0 with php-composer(phpunit/php-timer) < 7)
BuildRequires: (php-composer(sebastian/cli-parser) >= 2.0.1 with php-composer(sebastian/cli-parser) < 3)
BuildRequires: (php-composer(sebastian/code-unit) >= 2.0 with php-composer(sebastian/code-unit) < 3)
-BuildRequires: (php-composer(sebastian/comparator) >= 5.0.2 with php-composer(sebastian/comparator) < 6)
+BuildRequires: (php-composer(sebastian/comparator) >= 5.0.3 with php-composer(sebastian/comparator) < 6)
BuildRequires: (php-composer(sebastian/diff) >= 5.1.1 with php-composer(sebastian/diff) < 6)
BuildRequires: (php-composer(sebastian/environment) >= 6.1.0 with php-composer(sebastian/environment) < 7)
BuildRequires: (php-composer(sebastian/exporter) >= 5.1.2 with php-composer(sebastian/exporter) < 6)
@@ -99,7 +99,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^6.0.0",
# "sebastian/cli-parser": "^2.0.1",
# "sebastian/code-unit": "^2.0.0",
-# "sebastian/comparator": "^5.0.2",
+# "sebastian/comparator": "^5.0.3",
# "sebastian/diff": "^5.1.1",
# "sebastian/environment": "^6.1.0",
# "sebastian/exporter": "^5.1.2",
@@ -126,7 +126,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 3.0.1 with php-c
Requires: (php-composer(phpunit/php-timer) >= 6.0 with php-composer(phpunit/php-timer) < 7)
Requires: (php-composer(sebastian/cli-parser) >= 2.0.1 with php-composer(sebastian/cli-parser) < 3)
Requires: (php-composer(sebastian/code-unit) >= 2.0 with php-composer(sebastian/code-unit) < 3)
-Requires: (php-composer(sebastian/comparator) >= 5.0.2 with php-composer(sebastian/comparator) < 6)
+Requires: (php-composer(sebastian/comparator) >= 5.0.3 with php-composer(sebastian/comparator) < 6)
Requires: (php-composer(sebastian/diff) >= 5.1.1 with php-composer(sebastian/diff) < 6)
Requires: (php-composer(sebastian/environment) >= 6.1.0 with php-composer(sebastian/environment) < 7)
Requires: (php-composer(sebastian/exporter) >= 5.1.2 with php-composer(sebastian/exporter) < 6)
@@ -274,6 +274,10 @@ exit $ret
%changelog
+* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 10.5.37-1
+- update to 10.5.37
+- raise dependency on sebastian/comparator 5.0.3
+
* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 10.5.36-1
- update to 10.5.36