summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--ResourceOperationsTest.php4
-rw-r--r--composer.json11
-rw-r--r--php-sebastian-resource-operations2.spec66
4 files changed, 43 insertions, 42 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/ResourceOperationsTest.php b/ResourceOperationsTest.php
index 176bc0d..0e0fcc0 100644
--- a/ResourceOperationsTest.php
+++ b/ResourceOperationsTest.php
@@ -10,12 +10,12 @@
namespace SebastianBergmann\ResourceOperations;
-use PHPUnit_Framework_TestCase;
+use PHPUnit\Framework\TestCase;
/**
* @covers SebastianBergmann\ResourceOperations\ResourceOperations
*/
-class ResourceOperationsTest extends PHPUnit_Framework_TestCase
+class ResourceOperationsTest extends TestCase
{
/**
* @covers SebastianBergmann\ResourceOperations\ResourceOperations::getFunctions
diff --git a/composer.json b/composer.json
index da495d6..0e05865 100644
--- a/composer.json
+++ b/composer.json
@@ -10,16 +10,23 @@
}
],
"require": {
- "php": ">=5.6.0"
+ "php": "^7.1"
},
"autoload": {
"classmap": [
"src/"
]
},
+ "config": {
+ "platform": {
+ "php": "7.1.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "1.0.x-dev"
+ "dev-master": "2.0"
}
}
}
diff --git a/php-sebastian-resource-operations2.spec b/php-sebastian-resource-operations2.spec
index 0c40b69..04e3a0d 100644
--- a/php-sebastian-resource-operations2.spec
+++ b/php-sebastian-resource-operations2.spec
@@ -1,13 +1,13 @@
-# remirepo/fedora spec file for php-sebastian-resource-operations
+# remirepo/fedora spec file for php-sebastian-resource-operations2
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ce990bb21759f94aeafd30209e8cfcdfa8bc3f52
+%global gh_commit 756a75a44cb3164fd47435c36336e464c5028b34
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -15,37 +15,36 @@
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project ResourceOperations
+%global major 2
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-sebastian-resource-operations
-Version: 1.0.0
-%global specrel 2
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Name: php-sebastian-resource-operations%{major}
+Version: 2.0.0
+%global specrel 1
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Provides a list of PHP built-in functions that operate on resources
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
# https://github.com/sebastianbergmann/resource-operations/pull/2
Source1: https://raw.githubusercontent.com/remicollet/resource-operations/issue-tests/tests/ResourceOperationsTest.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: phpunit7
%endif
# from composer.json
-# "php": ">=5.6.0"
-Requires: php(language) >= 5.6
+# "php": "^7.1"
+Requires: php(language) >= 7.1
# Autoloader
Requires: php-composer(fedora/autoloader)
# from phpcompatinfo report for version 1.0.0: nothing
@@ -72,50 +71,41 @@ phpab --template fedora --output src/autoload.php src
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
-cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
%if %{with_tests}
: Run upstream test suite
-# remirepo:13
-run=0
+: Run upstream test suite
ret=0
-if which php56; then
- php56 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests || ret=1
- run=1
-fi
-if which php71; then
- php71 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
-%{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests --verbose
-# remirepo:2
-fi
+for cmd in php php71 php72 php73; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit7 --verbose tests || ret=1
+ fi
+done
exit $ret
%else
: bootstrap build with test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
%dir %{php_home}/%{ns_vendor}
- %{php_home}/%{ns_vendor}/%{ns_project}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
%changelog
+* Fri Sep 28 2018 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP 7.1
+- rename to php-sebastian-resource-operations2
+- move to /usr/share/php/SebastianBergmann/ResourceOperations2
+
* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
- switch to fedora/autoloader