summaryrefslogtreecommitdiffstats
path: root/php-sebastian-code-unit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-code-unit.spec')
-rw-r--r--php-sebastian-code-unit.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-sebastian-code-unit.spec b/php-sebastian-code-unit.spec
index f499830..741395f 100644
--- a/php-sebastian-code-unit.spec
+++ b/php-sebastian-code-unit.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Sources
-%global gh_commit d650ef9b1fece15ed4d6eaed6e6b469b7b81183a
+%global gh_commit c1e2df332c905079980b119c4db103117e5e5c90
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit
@@ -21,13 +21,13 @@
%global ns_vendor SebastianBergmann
%global ns_project CodeUnit
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.3
+Version: 1.0.5
Release: 1%{?dist}
Summary: Collection of value objects that represent the PHP code units
@@ -42,14 +42,14 @@ BuildRequires: php-reflection
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json, "require": {
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# From phpcompatinfo report for 1.0.0
Requires: php-reflection
@@ -89,12 +89,14 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
-%if %{with_tests}
+%if %{with tests}
%check
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
+
require_once dirname(__DIR__) . '/tests/_fixture/autoload.php';
+require_once dirname(__DIR__) . '/tests/_fixture/file_with_multiple_code_units.php';
require_once dirname(__DIR__) . '/tests/_fixture/function.php';
EOF
@@ -120,6 +122,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 1.0.3-1
- update to 1.0.3 (no change)
- sources from git snapshot