summaryrefslogtreecommitdiffstats
path: root/php-phpunit-selenium.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-selenium.spec')
-rw-r--r--php-phpunit-selenium.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/php-phpunit-selenium.spec b/php-phpunit-selenium.spec
index 45a51a5..7349f16 100644
--- a/php-phpunit-selenium.spec
+++ b/php-phpunit-selenium.spec
@@ -1,42 +1,41 @@
# remirepo/fedora spec file for php-phpunit-selenium
#
-# Copyright (c) 2010-2017 Remi Collet
+# Copyright (c) 2010-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 9872e1d452f44976ca9f4e3fab2a33f8f9c4bcdc
+%global gh_commit 3129be3c3a90bf46ef301817ea67c2f525451963
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner giorgiosironi
%global gh_project phpunit-selenium
%global pk_vendor phpunit
%global pk_project %{gh_project}
-%global php_home %{_datadir}/php/PHPUnit6
+%global php_home %{_datadir}/php/PHPUnit7
# No test, as test suite requires a Selenium server
Name: php-%{pk_project}
-Version: 4.1.0
-Release: 2%{?dist}
+Version: 7.0.0
+Release: 1%{?dist}
Summary: Selenium RC integration for PHPUnit
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
# From composer.json
-# "php": ">=7.0",
-# "phpunit/phpunit": ">=6.0,<7.0",
+# "php": ">=7.1",
# "ext-curl": "*"
-Requires: php(language) >= 7.0
-Requires: phpunit6
+# "phpunit/phpunit": ">=7.0,<8.0",
+Requires: php(language) >= 7.1
Requires: php-curl
-# From phpcompatinfo report for version 4.1.0
+Requires: phpunit7
+# From phpcompatinfo report for version 7.0.0
Requires: php-date
Requires: php-json
Requires: php-pcre
@@ -85,6 +84,11 @@ cp -pr PHPUnit/* %{buildroot}%{php_home}
%changelog
+* Thu Jul 4 2019 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0
+- raise dependency on PHP 7.1
+- switch from PHPUnit 6 to 7
+
* Wed Sep 6 2017 Remi Collet <remi@remirepo.net> - 4.1.0-2
- fix dir ownsership, from review #1485924