summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--php-phpunit-selenium.spec23
2 files changed, 18 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 97ff7e7..41f1af4 100644
--- a/composer.json
+++ b/composer.json
@@ -8,7 +8,7 @@
"testing",
"selenium"
],
- "homepage": "http://www.phpunit.de/",
+ "homepage": "https://github.com/giorgiosironi/phpunit-selenium",
"license": "BSD-3-Clause",
"authors": [
{
@@ -40,13 +40,12 @@
}
],
"support": {
- "issues": "https://github.com/sebastianbergmann/phpunit-selenium/issues",
- "irc": "irc://irc.freenode.net/phpunit"
+ "issues": "https://github.com/giorgiosironi/phpunit-selenium/issues"
},
"require": {
- "php": ">=7.1",
+ "php": ">=7.2",
"ext-curl": "*",
- "phpunit/phpunit": ">=7.0,<8.0"
+ "phpunit/phpunit": ">=8.0,<9.0"
},
"require-dev": {
"phing/phing": "2.*"
diff --git a/php-phpunit-selenium.spec b/php-phpunit-selenium.spec
index 7349f16..ff65523 100644
--- a/php-phpunit-selenium.spec
+++ b/php-phpunit-selenium.spec
@@ -1,22 +1,22 @@
# remirepo/fedora spec file for php-phpunit-selenium
#
-# Copyright (c) 2010-2019 Remi Collet
+# Copyright (c) 2010-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 3129be3c3a90bf46ef301817ea67c2f525451963
+%global gh_commit 7c8bef67f1e206044bbb8e873402c696611ada43
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner giorgiosironi
%global gh_project phpunit-selenium
%global pk_vendor phpunit
%global pk_project %{gh_project}
-%global php_home %{_datadir}/php/PHPUnit7
+%global php_home %{_datadir}/php/PHPUnit8
# No test, as test suite requires a Selenium server
Name: php-%{pk_project}
-Version: 7.0.0
+Version: 8.0.0
Release: 1%{?dist}
Summary: Selenium RC integration for PHPUnit
@@ -25,17 +25,17 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.2
BuildRequires: php-fedora-autoloader-devel
# From composer.json
# "php": ">=7.1",
# "ext-curl": "*"
-# "phpunit/phpunit": ">=7.0,<8.0",
-Requires: php(language) >= 7.1
+# "phpunit/phpunit": ">=8.0,<9.0",
+Requires: php(language) >= 7.2
Requires: php-curl
-Requires: phpunit7
-# From phpcompatinfo report for version 7.0.0
+Requires: phpunit8
+# From phpcompatinfo report for version 8.0.0
Requires: php-date
Requires: php-json
Requires: php-pcre
@@ -84,6 +84,11 @@ cp -pr PHPUnit/* %{buildroot}%{php_home}
%changelog
+* Tue Mar 17 2020 Remi Collet <remi@remirepo.net> - 8.0.0-1
+- update to 8.0.0
+- raise dependency on PHP 7.2
+- switch from PHPUnit 7 to 8
+
* Thu Jul 4 2019 Remi Collet <remi@remirepo.net> - 7.0.0-1
- update to 7.0.0
- raise dependency on PHP 7.1