summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-11 07:26:11 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-11 07:26:11 +0100
commit534018416f962f7e2924730149f0287766e8ff4a (patch)
tree736bb96d87114f800acfa751017a17809b1199a1
parentba7e9870bed0d10f7cbe0a631b368700040d5987 (diff)
php-phpunit-phploc: 2.1.0
-rw-r--r--php-phpunit-phploc.spec35
-rw-r--r--phploc-rpm.patch12
2 files changed, 26 insertions, 21 deletions
diff --git a/php-phpunit-phploc.spec b/php-phpunit-phploc.spec
index 40ba1f6..48af2b5 100644
--- a/php-phpunit-phploc.spec
+++ b/php-phpunit-phploc.spec
@@ -1,4 +1,4 @@
-%global gh_commit 322ad07c112d5c6832abed4269d648cacff5959b
+%global gh_commit 0e7ead01180d93536dec14da10d038a62d9f509d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phploc
@@ -8,7 +8,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-phpunit-phploc
-Version: 2.0.6
+Version: 2.1.0
Release: 1%{?dist}
Summary: A tool for quickly measuring the size of a PHP project
@@ -25,34 +25,34 @@ Patch0: %{gh_project}-rpm.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: php(language) >= 5.3.3
+BuildRequires: php(language) >= 5.4
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
BuildRequires: %{_bindir}/phpunit
BuildRequires: php-composer(sebastian/finder-facade) >= 1.1
BuildRequires: php-composer(sebastian/finder-facade) < 2
-BuildRequires: php-composer(sebastian/git) >= 1.0
-BuildRequires: php-composer(sebastian/git) < 2
-BuildRequires: php-composer(sebastian/version) >= 1.0
+BuildRequires: php-composer(sebastian/git) >= 2.0
+BuildRequires: php-composer(sebastian/git) < 3
+BuildRequires: php-composer(sebastian/version) >= 1.0.3
BuildRequires: php-composer(sebastian/version) < 2
-BuildRequires: php-symfony-console >= 2.2
+BuildRequires: php-symfony-console >= 2.5
BuildRequires: php-symfony-console < 3
%endif
# From composer.json
# "php": ">=5.3.3",
# "sebastian/finder-facade": "~1.1",
-# "sebastian/git": "~1.0",
-# "sebastian/version": "~1.0",
-# "symfony/console": "~2.2"
-Requires: php(language) >= 5.3.3
+# "sebastian/git": "~2.0",
+# "sebastian/version": "~1.0.3",
+# "symfony/console": "~2.5"
+Requires: php(language) >= 5.4
Requires: php-composer(sebastian/finder-facade) >= 1.1
Requires: php-composer(sebastian/finder-facade) < 2
-Requires: php-composer(sebastian/git) >= 1.0
-Requires: php-composer(sebastian/git) < 2
-Requires: php-composer(sebastian/version) >= 1.0
+Requires: php-composer(sebastian/git) >= 2.0
+Requires: php-composer(sebastian/git) < 3
+Requires: php-composer(sebastian/version) >= 1.0.3
Requires: php-composer(sebastian/version) < 2
-Requires: php-symfony-console >= 2.2
+Requires: php-symfony-console >= 2.5
Requires: php-symfony-console < 3
# From phpcompatinfo report for version 2.0.5
Requires: php-dom
@@ -123,6 +123,11 @@ fi
%changelog
+* Wed Mar 11 2015 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
+- update to 2.0.6
+- raise dependencies on sebastian/git 2.0, symfony/console 2.5
+- raise minimal PHP version to 5.4
+
* Wed Jun 25 2014 Remi Collet <remi@fedoraproject.org> - 2.0.6-1
- update to 2.0.6
- composer dependencies
diff --git a/phploc-rpm.patch b/phploc-rpm.patch
index fc04bb6..62f5c6b 100644
--- a/phploc-rpm.patch
+++ b/phploc-rpm.patch
@@ -1,14 +1,14 @@
diff -up ./phploc.rpm ./phploc
---- ./phploc.rpm 2014-05-03 18:50:56.000000000 +0200
-+++ ./phploc 2014-05-03 18:51:38.000000000 +0200
+--- ./phploc.rpm 2015-03-11 07:14:28.241134864 +0100
++++ ./phploc 2015-03-11 07:16:29.647622059 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
- /**
- * phploc
-@@ -42,23 +42,7 @@
- * @since File available since Release 1.0.0
+ /*
+ * This file is part of PHPLOC.
+@@ -9,23 +9,7 @@
+ * file that was distributed with this source code.
*/
-$loaded = false;