summaryrefslogtreecommitdiffstats
path: root/php-phpunit-phpcov.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-09-12 09:59:28 +0200
committerRemi Collet <fedora@famillecollet.com>2013-09-12 09:59:28 +0200
commitbb9a627854687d46b51b6f8f69ae44ba1c5bdc49 (patch)
tree73587f2a772e64a2c24ea36e4c18eed879093877 /php-phpunit-phpcov.spec
php-phpunit-phpcov: new package
Diffstat (limited to 'php-phpunit-phpcov.spec')
-rw-r--r--php-phpunit-phpcov.spec103
1 files changed, 103 insertions, 0 deletions
diff --git a/php-phpunit-phpcov.spec b/php-phpunit-phpcov.spec
new file mode 100644
index 0000000..3977be4
--- /dev/null
+++ b/php-phpunit-phpcov.spec
@@ -0,0 +1,103 @@
+# spec file for php-phpunit-phpcov
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name phpcov
+%global pear_channel pear.phpunit.de
+
+Name: php-phpunit-phpcov
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: TextUI frontend for PHP_CodeCoverage
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/phpcov
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# from package.xml
+Requires: php(language) >= 5.3.3
+Requires: php-pear(PEAR) >= 1.9.4
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(components.ez.no/ConsoleTools) >= 1.6
+Requires: php-pear(%{pear_channel}/PHPUnit) >= 3.7.0
+Requires: php-pear(%{pear_channel}/PHP_CodeCoverage) >= 1.2.0
+# from phpcompatinfo report for version 1.1.0
+Requires: php-reflection
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+# Project name
+Provides: phpcov = %{version}
+
+
+%description
+TextUI frontend for PHP_CodeCoverage.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/SebastianBergmann
+%{pear_phpdir}/SebastianBergmann/PHPCOV
+%{_bindir}/phpcov
+
+
+%changelog
+* Thu Sep 12 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- initial package