summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-timer3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-timer3.spec')
-rw-r--r--php-phpunit-php-timer3.spec14
1 files changed, 8 insertions, 6 deletions
diff --git a/php-phpunit-php-timer3.spec b/php-phpunit-php-timer3.spec
index 36ed92b..fda2b18 100644
--- a/php-phpunit-php-timer3.spec
+++ b/php-phpunit-php-timer3.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4118013a4d0f97356eae8e7fb2f6c6472575d1df
+%global gh_commit 35e732ff964693cb91ef4690f1f6016833b68f9d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -28,7 +28,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 3.1.2
Release: 1%{?dist}
Summary: PHP Utility class for timing
@@ -42,8 +42,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# From composer.json"require-dev": {
# "phpunit/phpunit": "^9.0"
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# From composer.json
@@ -85,10 +84,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -106,6 +105,9 @@ exit $ret
%changelog
+* Fri Apr 17 2020 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 7.3