summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-invoker3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-invoker3.spec')
-rw-r--r--php-phpunit-php-invoker3.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-phpunit-php-invoker3.spec b/php-phpunit-php-invoker3.spec
index 0c81072..b1b8a55 100644
--- a/php-phpunit-php-invoker3.spec
+++ b/php-phpunit-php-invoker3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 62f696ad0d140e0e513e69eaafdebb674d622b4c
+%global gh_commit f6eedfed1085dd1f4c599629459a0277d25f9a66
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
@@ -21,13 +21,13 @@
%global ns_project Invoker
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.1
+Version: 3.0.2
Release: 1%{?dist}
Summary: Invoke callables with a timeout
@@ -39,7 +39,7 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# From composer.json, require-dev
# "ext-pcntl": "*"
# "phpunit/phpunit": "^9.0"
@@ -48,7 +48,7 @@ BuildRequires: phpunit9
%endif
# From composer.json, require
-# "php": "^7.3",
+# "php": "^7.3 || ^8.0",
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 3.0.0
Requires: php-pcntl
@@ -81,7 +81,7 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
-%if %{with_tests}
+%if %{with tests}
%check
: Generate tests autoloader
mkdir vendor
@@ -110,6 +110,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1
- sources from git snapshot