summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-phpunit-php-invoker3.spec13
2 files changed, 13 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index a610ff0..6c007cd 100644
--- a/composer.json
+++ b/composer.json
@@ -19,15 +19,18 @@
},
"prefer-stable": true,
"config": {
+ "platform": {
+ "php": "7.3.0"
+ },
"optimize-autoloader": true,
"sort-packages": true
},
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
"ext-pcntl": "*",
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-invoker3.spec b/php-phpunit-php-invoker3.spec
index 02d1f7c..18d4c21 100644
--- a/php-phpunit-php-invoker3.spec
+++ b/php-phpunit-php-invoker3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7a85b66acc48cacffdf87dadd3694e7123674298
+%global gh_commit 5a10147d0aaf65b58940a0b72f71c9ac0423cc67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.1.0
+Version: 3.1.1
Release: 1%{?dist}
Summary: Invoke callables with a timeout
@@ -42,13 +42,13 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json, require-dev
# "ext-pcntl": "*"
-# "phpunit/phpunit": "^9.0"
+# "phpunit/phpunit": "^9.3"
BuildRequires: php-pcntl
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# From composer.json, require
-# "php": "^7.3 || ^8.0",
+# "php": ">=7.3",
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 3.0.0
Requires: php-pcntl
@@ -110,6 +110,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1 (no change)
+
* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
- update to 3.1.0