summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-phpunit-php-invoker3.spec30
2 files changed, 24 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index a610ff0..6c007cd 100644
--- a/composer.json
+++ b/composer.json
@@ -19,15 +19,18 @@
},
"prefer-stable": true,
"config": {
+ "platform": {
+ "php": "7.3.0"
+ },
"optimize-autoloader": true,
"sort-packages": true
},
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
"ext-pcntl": "*",
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-invoker3.spec b/php-phpunit-php-invoker3.spec
index 02d1f7c..df470c3 100644
--- a/php-phpunit-php-invoker3.spec
+++ b/php-phpunit-php-invoker3.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-phpunit-php-invoker3
#
-# Copyright (c) 2011-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2011-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7a85b66acc48cacffdf87dadd3694e7123674298
+%global gh_commit 5a10147d0aaf65b58940a0b72f71c9ac0423cc67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
@@ -27,11 +27,11 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.1.0
-Release: 1%{?dist}
-Summary: Invoke callables with a timeout
+Version: 3.1.1
+Release: 7%{?dist}
+Summary: Invoke callables with a timeout, version %{major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -42,13 +42,13 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json, require-dev
# "ext-pcntl": "*"
-# "phpunit/phpunit": "^9.0"
+# "phpunit/phpunit": "^9.3"
BuildRequires: php-pcntl
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# From composer.json, require
-# "php": "^7.3 || ^8.0",
+# "php": ">=7.3",
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 3.0.0
Requires: php-pcntl
@@ -62,6 +62,8 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
phpunit/php-invoker provides the means to invoke a callable with a timeout.
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
@@ -89,7 +91,7 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit9 --verbose || ret=1
@@ -110,6 +112,12 @@ exit $ret
%changelog
+* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 3.1.1-7
+- use SPDX License id
+
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1 (no change)
+
* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
- update to 3.1.0