summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-code-coverage5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-code-coverage5.spec')
-rw-r--r--php-phpunit-php-code-coverage5.spec20
1 files changed, 11 insertions, 9 deletions
diff --git a/php-phpunit-php-code-coverage5.spec b/php-phpunit-php-code-coverage5.spec
index affb586..b873b1a 100644
--- a/php-phpunit-php-code-coverage5.spec
+++ b/php-phpunit-php-code-coverage5.spec
@@ -9,7 +9,7 @@
%global bootstrap 0
# Github
-%global gh_commit 8e1d2397d8adf59a3f12b2878a3aaa66d1ab189d
+%global gh_commit 033ec97498cf530cc1be4199264cad568b19be26
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
%global ver_major 5
%global ver_minor 2
-%global ver_patch 3
+%global ver_patch 4
%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -43,7 +43,7 @@ Group: Development/Libraries
# ASL 2.0: nvd3
License: BSD and MIT and ASL 2.0
URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
# RPM specific changes: use system .ttf file
Patch0: %{name}-fonts.patch
@@ -55,7 +55,7 @@ BuildRequires: php(language) >= 7.0
BuildRequires: php-composer(phpunit/php-file-iterator) < 2
BuildRequires: php-composer(phpunit/php-file-iterator) >= 1.4.2
BuildRequires: php-composer(phpunit/php-token-stream) < 3
-BuildRequires: php-composer(phpunit/php-token-stream) >= 2.0
+BuildRequires: php-composer(phpunit/php-token-stream) >= 2.0.1
BuildRequires: php-composer(phpunit/php-text-template) < 2
BuildRequires: php-composer(phpunit/php-text-template) >= 1.2.1
BuildRequires: php-composer(sebastian/code-unit-reverse-lookup) < 2
@@ -78,7 +78,7 @@ BuildRequires: php-pecl-xdebug >= 2.5.5
# "ext-dom": "*",
# "ext-xmlwriter": "*",
# "phpunit/php-file-iterator": "^1.4.2",
-# "phpunit/php-token-stream": "^2.0",
+# "phpunit/php-token-stream": "^2.0.1",
# "phpunit/php-text-template": "^1.2.1",
# "sebastian/code-unit-reverse-lookup": "^1.0.1",
# "sebastian/environment": "^3.0",
@@ -90,7 +90,7 @@ Requires: php-xmlwriter
Requires: php-composer(phpunit/php-file-iterator) < 2
Requires: php-composer(phpunit/php-file-iterator) >= 1.4.2
Requires: php-composer(phpunit/php-token-stream) < 3
-Requires: php-composer(phpunit/php-token-stream) >= 2.0
+Requires: php-composer(phpunit/php-token-stream) >= 2.0.1
Requires: php-composer(phpunit/php-text-template) < 2
Requires: php-composer(phpunit/php-text-template) >= 1.2.1
Requires: php-composer(sebastian/code-unit-reverse-lookup) < 2
@@ -185,7 +185,6 @@ fi
cat << 'EOF' | tee tests/bootstrap.php
<?php
-require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php';
require __DIR__ . '/TestCase.php';
define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
@@ -194,9 +193,8 @@ ret=0
for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd $EXT \
- -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+ -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
%{_bindir}/phpunit6 \
- --filter '^((?!(testForClassWithAnonymousFunction|testTextForClassWithAnonymousFunction|testGetLinesToBeIgnored3|testCloverForClassWithAnonymousFunction)).)*$' \
--verbose || ret=1
fi
done
@@ -214,6 +212,10 @@ exit $ret
%changelog
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 5.2.4-1
+- Update to 5.2.4
+- raise dependency on phpunit/php-token-stream 2.0.1
+
* Mon Nov 6 2017 Remi Collet <remi@remirepo.net> - 5.2.3-1
- Update to 5.2.3
- raise dependency on phpunit/php-token-stream 2.0