summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--554.patch23
-rw-r--r--php-phpunit-php-code-coverage5.spec23
2 files changed, 38 insertions, 8 deletions
diff --git a/554.patch b/554.patch
new file mode 100644
index 0000000..2869666
--- /dev/null
+++ b/554.patch
@@ -0,0 +1,23 @@
+From 71d0493b6817352134317f504eb55e8ce7c7f669 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 3 Nov 2017 13:55:50 +0100
+Subject: [PATCH] Fix count(): Parameter must be an array or an object that
+ implements Countable
+
+---
+ src/Report/Html/Renderer/File.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Report/Html/Renderer/File.php b/src/Report/Html/Renderer/File.php
+index 8f2c929b..975bc0a0 100644
+--- a/src/Report/Html/Renderer/File.php
++++ b/src/Report/Html/Renderer/File.php
+@@ -304,7 +304,7 @@ protected function renderSource(FileNode $node)
+ $popoverTitle = '';
+
+ if (array_key_exists($i, $coverageData)) {
+- $numTests = count($coverageData[$i]);
++ $numTests = ($coverageData[$i] ? count($coverageData[$i]) : 0);
+
+ if ($coverageData[$i] === null) {
+ $trClass = ' class="warning"';
diff --git a/php-phpunit-php-code-coverage5.spec b/php-phpunit-php-code-coverage5.spec
index 094a793..fec4509 100644
--- a/php-phpunit-php-code-coverage5.spec
+++ b/php-phpunit-php-code-coverage5.spec
@@ -24,7 +24,7 @@
%global ver_major 5
%global ver_minor 2
%global ver_patch 2
-%global specrel 2
+%global specrel 3
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
@@ -48,6 +48,8 @@ Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commi
# RPM specific changes: use system .ttf file
Patch0: %{name}-fonts.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-code-coverage/pull/554.patch
+
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
@@ -140,6 +142,7 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch1 -p1
%if %{with_glyphicons}
%patch0 -p0 -b .rpm
@@ -187,14 +190,13 @@ define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
ret=0
-# TODO: PHP 7.2
-# 1) SebastianBergmann\CodeCoverage\Report\Html\HTMLTest::testForBankAccountTest
-# count(): Parameter must be an array or an object that implements Countable
-
-for cmd in php php70 php71; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
- $cmd $EXT -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
- %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
+ $cmd $EXT \
+ -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+ %{_bindir}/phpunit6 \
+ --filter '^((?!(testForClassWithAnonymousFunction|testTextForClassWithAnonymousFunction|testGetLinesToBeIgnored3|testCloverForClassWithAnonymousFunction)).)*$' \
+ --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -211,6 +213,11 @@ exit $ret
%changelog
+* Fri Nov 3 2017 Remi Collet <remi@remirepo.net> - 5.2.2-3
+- fix FTBFS from Koschei, add patch for PHP 7.2 from
+ https://github.com/sebastianbergmann/php-code-coverage/pull/554
+- ignore test failing, know by upstream (travis)
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 5.2.2-2
- allow phpunit/php-token-stream v2